X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

None of your solutions is appropriate. Can't download Flash player either

Posted

I am running Leopard (10.5.8) on my PowerBook G4. I tried to update to Snow Leopard but said I couldn't so I am figuring can't get Mountain Lion. That means I can't get upload a new version of Firefox and can't get Flashplayer. It is NOT possible to get a newer computer. What are my options.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello aal818, the only option you have to be secure and update is to change to TenFourFox

see also : tenfourfox - ReleaseNotes

Why aren't plugins supported in TenFourFox? Why can't I use Flash?


thank you