Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get a previous version of Firefox. Firefox 17 does not work with online banking

  • 22 replies
  • 8 have this problem
  • Last reply by chriswchris

more options

How do I get a previous version of Firefox. Firefox 17 does not work with online banking edit

Chosen solution

Similarly I am now (with v 17) unable to initiate a download from a website to Quicken. At least it appears with the four different financial institutions I've tried. All of them worked before version 17. I am now on 17.0.1 so that didn't fix the problem.

Read this answer in context 👍 0

All Replies (20)

more options

Hi rmbeesley

try to clear cookies and cache from Tools > History > Clear Recent History > Time range to clear select Everything > click on Details and check Cookies and Cache > Clear Now .

also be sure you have check mark in Accept cookies from sites[ v ] and to Accept third party cookies [ v ], see : How do I change Cookie settings?

If the above does not solve the issue, try to delete the cookies.sqlite file and any cookies.sqlite-journal files in profile folder(in case cookies are corrupted), see how to do that : Remove corrupt cookies file

thank you

more options

The suggestions did not help as I have tried this before. The problem is with Firefox version 17.0. It is defective and should be removed. I need a previous version of Firefox. If I can not get a previous version of Firefox or a fix for Firefox 17.0 is not issued by Monday November 26 I will have to stop using Firefox and use another browser.

more options

please specify what you're meaning by "does not work with online banking" - what exactly is going wrong (what are you trying to do, on which web address, are there any error messages, etc.) - without this information it is impossible to troubleshoot or address the issue...

more options

Using Firefox 17.0 I was able to get to my banks online banking site ( and login to my account. When I tried to do Bill payments, check History, do a Transfer I got the following error from my banks site. "We have encountered an error processing your request. Click on the back button to continue." If I clicked on the back button I would get to my main account page or get to main login page depending on what type of banking I was trying to do.

I then went to a different computer with Firefox 15 (I believe) and was able to access all banking types(Bill payment etc). I then updated this workstation to Firefox 17 and got the same problems as with the first workstation. I tried deleting all cookies, temp files and restated the computer. That did not solve anything. I call my bank for Tech support and they said there is a problem with Firefox 17.0 and no other browsers including previous version of Firefox. They said they are looking to see if there is a solution and to use another browser as a temporary fix.

I have asked the question, How do I get a previous version of Firefox, and no one has answered the question.

more options
more options

ok ,since the problem can apparently only be reproduced logged in with an account of this bank it is difficult to access from outside what may be going wrong.

in this case i'd recommend downloading a portable version of firefox 16 & using it for this online banking site only and your main firefox 17 for everything else, until the bank can find and fix the issue.

more options

Jan: Thanks for the local of previous versions of Firefox I installed Firefox 16.0.2 and the problems with online banking have been resolved.

Madperson: a portable version of Firefox is not an appropriate fix for a desktop application.

Firefox 17.0 is the problem not my bank.

more options

The portable version is indeed a useful option as it can be installed either on a usb flash drive or on hard disk. The Profile is also kept with the program folder so it basically does not interfere with the Firefox 17.0 install or and Profiles you have with 17.0.

more options

I just saw a similar question on the newsgroup where a Firefox 17 user was getting the error,
An unexpected system error occurred. Please try your request later. If the problem persists, please contact customer service.
(see this post on google groups)

The person contacted his bank and the bank wrote back, At this time Firefox 17.0 is not a supported browser for Meriwest Online Banking. Our IT department is reviewing this new version of Firefox. You should be able to process your request using another browser or an earlier version of Firefox.

In that case, the solution was to change the user agent string in Firefox 17 to the following, to "fool" the website into thinking it was Firefox 16:

Mozilla/6.0 (Windows NT 6.2; WOW64; rv:16.0.1) Gecko/20121011 Firefox/16.0.1

You can use the User Agent Switcher extension to do that, as an alternative to downgrading or installing Firefox Portable.

If you need help using that extension to disguise Firefox, see the How to reset the default user agent on Firefox article's "Workaround for broken websites" section. Link:

more options

Hi rmbeesley,

Any chance we could get you to try using 17 and the user agent workaround suggested by AliceWyman to verify that is the issue? It would help us a great deal since you have to be logged in to reproduce the error you reported.


more options

Firefox 17.0.1 will fix a number of issues related to website incompatibility, including problems with some online banking sites ( ref.) . You should try updating to Firefox 17.0.1 when it comes out.

more options

P.S. Firefox 17.0.1 is supposed to be released Friday (ref.) so you should start checking for updates tomorrow by going to the Firefox Help menu and clicking on "About Firefox". See Update Firefox to the latest release for more information.

more options

Chosen Solution

Similarly I am now (with v 17) unable to initiate a download from a website to Quicken. At least it appears with the four different financial institutions I've tried. All of them worked before version 17. I am now on 17.0.1 so that didn't fix the problem.

more options
more options

If that suggestion was for me, I'm not sure why you suggested that link. I did not receive any notice of a certificate problem, and I somehow doubt there would be certificate problems with four separate financial institutions -- suddenly with v 17.

I should be more specific about my problem symptoms: I login to a website, and tell the site to download to Quicken 2010. I am asked (by FF I assume) whether I want to open the file or save it. If I tell it to open the file using the Quicken Launcher (the usual way to handle site-initiated downloads), Quicken responds with a nonsense question to which any answer gets me nowhere. It is pretty obvious that Quicken has not received proper info from the site through FF. This happens on four sites now, but did not with earlier FF. It also happens whether Quicken is open or not. Quicken version has not changed recently. (If it matters, IE works fine.)

If I select save instead of open, I can manually import that file into Quicken with no problem. (That's what I have been doing, but I don't like the extra step for each institution.)

Sorry I didn't give the detail initially.

I put my report/question here since it is related to v 17, but it's not identical. Should I start a separate thread?

more options

I wasn't as direct as I should have been either, sorry about that. I don't think I had a certificate problem, it was something more general in the guts of 17. The Reset button apparently fixes a variety of sins, so it might fix yours as well...can't hurt to try. But save your profiles, bookmarks, etc, before you do anything, Reset seems to shake things up quite a bit.

more options

And in desperation, 16 portable might work.

more options

As of today, I cannot even load the front page of my bank, much less log on to it. There are a number of other websites that I can't load either. I get one of those "Unable to connect" messages every day.

Everything was fine until I foolishly updated my Firefox.

more options

Try the Reset I mentioned above. If that doesn't work, try a uninstall/reinstall. I've been wondering if after many updates/upgrades (I started FF maybe ten versions ago), the open-source approach loses "institutional memory" (eg, a programmer on 17 writes something that conflicts with something-not-obvious in 6 )

more options

Uninstalling and re-installing seems to have done the trick so far. Got into my bank's website without a problem.

I'm optimistic, as it's loaded another page that didn't load before. Yea!!!



  1. 1
  2. 2