X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do i change the default search engine in the search bar?

Posted

Whenever i open firefox the default search engine in the little search bar is always Yahoo, and nothing i do changes it back to google permanently. Even when i type something in the address bar it uses yahoo. Ive tried everything including going in to about:config and changing a bunch of stuff like putting in the google string but nothing works...

Chosen solution

hello jonhon8, this sounds like a problem that may be caused by adware on your pc. please go to firefox > addons > extensions & remove any suspicious entries (toolbars, things that you have not installed intentionally, etc). also go to the windows control panel / programs and remove all toolbars or potentially unwanted software from there and do a full scan of your system with the security software that you have in place and/or a different tool like the free version of malwarebytes.

Remove a toolbar that has taken over your Firefox search or home page

afterwards install the search reset addon - it will revert the most common customizations by those adware programs back to the firefox default: https://addons.mozilla.org/firefox/addon/searchreset/

Read this answer in context 28

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • VLC media player Web Plugin 2.0.2
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • np-mswmp
  • iTunes Detector Plug-in
  • TS Plug-in Version 1.0.6.1, Copyright (c) 2009, VideoLAN and Delft University of Technology and Torrent Stream http://torrentstream.org
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • npdivxplayerplugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

Chosen Solution

hello jonhon8, this sounds like a problem that may be caused by adware on your pc. please go to firefox > addons > extensions & remove any suspicious entries (toolbars, things that you have not installed intentionally, etc). also go to the windows control panel / programs and remove all toolbars or potentially unwanted software from there and do a full scan of your system with the security software that you have in place and/or a different tool like the free version of malwarebytes.

Remove a toolbar that has taken over your Firefox search or home page

afterwards install the search reset addon - it will revert the most common customizations by those adware programs back to the firefox default: https://addons.mozilla.org/firefox/addon/searchreset/

TerryOdell 0 solutions 6 answers

I tried this, but when I restarted Firefox this morning, Yahoo was still my default search engine, and all the others I'd removed were back. It's not hard to put things back the way I want them, but it's a pain to have to do it daily. I've removed the Yahoo toolbar as well as other add-ons I don't recognize, but it's not a toolbar issue, it's the search engine thing.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96741 answers

Is this about the search engine on the Navigation Toolbar or the search engine used on the about:home page?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

If you do not keep changes after a restart then see:

Try to delete the search.json file and a possible search.sqlite file in the Firefox Profile Folder.

You can look at this version of SearchReset (updated by me) that also resets the search engine used on the about:home page:

TerryOdell 0 solutions 6 answers

It's the search engine selected in the nav bar (the one at the far right). I don't want to try what you've suggested until it's confirmed your instructions are for this question. Frankly, what you're telling me to do is totally scary. I am NOT a techno person. I also noticed that when I restarted my computer my default home page in Firefox was no longer the one I'd set it for. So, whatever the add on suggested originally was supposed to do, it didn't.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96741 answers

Do you have a user.js file in the Firefox Profile Folder?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

Are you able to keep the Google search engine if you run Firefox in Safe mode?

TerryOdell 0 solutions 6 answers

Yes I found the user.js file, but you didn't say what to do with it.

I restarted in safe mode and Yahoo came right back as my default search engine.
cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96741 answers

Can you open that file in Notepad for inspection (right-click: Open with; do not double click) and post its content?

You need to delete that user.js file as it shouldn't be there and is probably added by an extension or other software.
This file is read at every start of Firefox to initialize setting stored in it.

TerryOdell 0 solutions 6 answers

Thanks -- this is what the file says: user_pref("yahoo.ytff.general.dontshowhpoffer", true);

You asked me to post so I'm doing that before I delete that file.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96741 answers

That pref seems to have been added by the Yahoo toolbar.

Do you have that extension (toolbar)?

You can delete the user.js file.

TerryOdell 0 solutions 6 answers

I don't have the Yahoo toolbar; I deleted it when I started this process. I deleted the user.js file. I closed Firefox and reopened it. The same search engines are still there, and now it opened onto a Yahoo search page instead of my home page.

I give up. I'll see what happens when I reboot, but I actually have 'real' work to do, and unless there's a fix that's going to work, it's probably easier to adjust the search choices when I start Firefox rather than take a chance on messing up yet something else.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96741 answers

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

LoveMusic 0 solutions 2 answers

My problem was that the upper right corner search bar kept reverting to Yahoo (which is also my default homepage site) even after I deleted it in the Manage Search Engines list. Here's how I solved it:

1) In the Firefox browser upper right pulldown Manage Search Engines; delete the unwanted zombie (mine was Yahoo).

2) In the url address bar type about:config, and search for Yahoo.

3) If it shows Yahoo in browser.search.selectedengine, right click and modify to your preferred search engine name (mine is Google).

This seems to be working ... so far.

Modified by LoveMusic

TerryOdell 0 solutions 6 answers

When I type about:config, I get a popup that says, 'This might void your warranty! Changing these advanced settings can be harmful to the stability, security, and performance of this application. You should only continue if you are sure of what you are doing.'

Well, I'm clueless and it's still easier to curse a little and simple click Google instead of Yahoo when Firefox starts up.

LoveMusic 0 solutions 2 answers

Perform all the steps except replacing the unwanted engine a few times until you are confident you can always repeat the steps to find the same line.

You will only be changing one string from myzombie (yahoo for me) within the config parameter 'browser.search.selectedengine' to Google.

Write down the name of the parameter you are changing and you can always change it back again by searching on the parameter name.

Worst case is you use Inet Explorer while you uninstall & reinstall FFox.

Biker451 0 solutions 4 answers

Helpful Reply

I'd tried everything suggested and even the one reply that had the right answer didn't do a good job of pointing to the answer. So:

Look at the search box on the tool-bar. Between the Yahoo logo and the word "Yahoo" you will see a very small down arrow. Left click on it and in the drop down menu the last item is "manage search engines", then when in there just highlight and "remove" any search engines that you don't want.

Once I saw that little down arrow it was one of those slap-your-forehead kind of moments. Click on the below thumbnail to see the instructions graphically:

Modified by Biker451

Shaukeen 0 solutions 1 answers

I had the same problem because of some Findr toolbar and the issue remained even after uninstalling the toolbar. Though I solved this problem by resetting the Keyword.URL value in about:config page.

Try this... http://superuser.com/questions/253879/change-the-default-search-engine-for-firefoxs-address-bar

ppltom 0 solutions 2 answers

Helpful Reply

Find the link below with all this explained for firefox, chrome, explorer.

Great tutorial with pictures

How to change address bar search

zdarma 0 solutions 1 answers

I think I had the same problem as you. If you want to be able to change the default engine from the address bar, where you would type for example www.google.com, you should look at this site:

http://superuser.com/questions/253879/change-the-default-search-engine-for-firefoxs-address-bar

I found the solution to my problem in 2 seconds. It will even show you how to modify for different search engines.