X
Tap here to go to the mobile version of the site.

Support Forum

Is FF V17 update compatable with Mac os x 10.6.8 and where can i find this info for future updates?

Posted

I got caught out once after an upgrade on a previous vers of Mac OS X when FF ceased to work so don't want to make the same mistake!

I got caught out once after an upgrade on a previous vers of Mac OS X when FF ceased to work so don't want to make the same mistake!

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • 2.0.31005.0
  • RealPlayer Plugin
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23381 answers

Helpful Reply

hello Caznco, yes firefox 17 is compatible with your OS - you can refer to www.mozilla.org/en-US/firefox/17.0/system-requirements/ (for future versions you'd have to exchange the version number in the url).

hello Caznco, yes firefox 17 is compatible with your OS - you can refer to www.mozilla.org/en-US/firefox/17.0/system-requirements/ (for future versions you'd have to exchange the version number in the url).

Question owner

Thank you! (It would help if there was a link from 'view more info' in the update window.)

Thank you! (It would help if there was a link from 'view more info' in the update window.)
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23381 answers

Helpful Reply

i think the "view more info" link leads to the version's release notes - there on the right site is a 4-point-list titled "try firefox", the first link ("check") also leads to the system requirements...

i think the "view more info" link leads to the version's release notes - there on the right site is a 4-point-list titled "try firefox", the first link ("check") also leads to the system requirements...