X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't access add-ons.mozilla.com account

Posted

Can't access add-ons.mozilla.com account

I've an account at add-ons.mozilla.com simply to keep track of the addons I use. But for sometime now I can't properly log in. After filling in my log-in info and clicking "log in" I just get redirected to the main page which still shows "register or log in" at the top of it. There's no error message or anything.

After clean re-install of Firefox I was able to access the account once - see my collections, change my profile, etc. - but simply leaving the account overview was enough for the website to consider me as not being logged in: "register or log in" at the top of the page instead of my account name and clicking on "add to collection" gives the "to create your own collections [...] log in [...]" pop up. I did not visit another site or install anything in between.

Everything I tried to fix this myself: - deleted cache, cookies, history, active logins - disabled all addons - tried to log in while "Private Browsing" was active - tried to log in using Google Chrome - typing in an incorrect password gives the expected error message (Please enter a correct username and password. Note that both fields are case-sensitive.) - requested password reset and successfully reset password - created a new account with a different email, successfully confirmed email all of these ended with the same failure to log in.

No matter from which angle I approach it I get redirected to the main page (same as you would if the log in were successful) but it doesn't register me as being logged in, won't let me access my account, see or add to my collections.

Chosen solution

Sorry, I've missed some parts of your above post about what you've tried so far.

Did you try to disable the Firefox Password Manager?

  • Tools > Options > Security: Passwords: [] "Remember passwords for sites"

Such issues can also happen if there are multiple entries (possibly with a blank name) in the Password Manager.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Sony Reader Application Detector Plugin
  • VLC media player Web Plugin 2.0.2
  • Picasa plugin
  • 5.1.10411.0
  • GEPlugin
  • NPWLPG
  • Windows Multimedia Services DRM Store Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Adblock Plus Pop-up Addon
0.5
true
adblockpopups@jessehakanen.net
Canadian English Dictionary
2.0.5
true
en-CA@dictionaries.addons.mozilla.org
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Element Hiding Helper for Adblock Plus
1.2.3
true
elemhidehelper@adblockplus.org
FlashGot
1.4.8.6
true
{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}
Greasemonkey
1.5
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Image Toolbar
0.6.9
true
{A4732521-77D9-447E-A557-B279AC923F06}
LiveJournal Hook
3.2.3
true
{D469DA71-A9C6-48f1-B86E-67313AADB588}
LJlogin
2.2.1
true
{ad4ee9e5-49c7-4589-acf3-db9fa76a95c9}
Missing e
2.14.1
true
jid0-0PGffAcVvhUBieFYkRVVc5w6lIU@jetpack
Muter
0.9.8
true
muter@yxl.name
Personas
1.6.2
true
personas@christopher.beard
Pocket
3.0.0
true
isreaditlater@ideashower.com
ScrapBook
1.5.5
true
{53A03D43-5363-4669-8190-99061B2DEBA5}
Session Manager
0.7.9.1
true
{1280606b-2510-4fe0-97ef-9b5a22eafe30}
Stylish
1.3
true
{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}
Tab Mix Plus
0.4.0.4pre.120724a
true
{dc572301-7619-498c-a57d-39143191b318}
Text Link
4.0.2011021601
true
{54BB9F3F-07E5-486c-9B39-C7398B99391C}
Thumbnail Zoom Plus
2.3
true
thumbnailZoom@dadler.github.com
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
browser.tabs.warnOnClose
false
extensions.lastAppVersion
17.0
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
privacy.cpd.extensions-sessionmanager
false
privacy.cpd.extensions-tabmix
false
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
ATI Radeon HD 5570
Vendor ID
0x1002
Device ID
0x68d9
Adapter RAM
2048
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
9.2.0.0
Driver Date
9-27-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17514)
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300
WebGL Renderer
Google Inc. -- ANGLE (ATI Radeon HD 5570) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

This can be caused by corrupted cookies or cookies that aren't send or otherwise blocked.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

You can also try Private Browsing mode to see if that allows to log in.

Question owner

I'm sorry but why did I bother with typing in all those information if all I get is a standard reply that doesn't take any of them into account?

I deleted everything, tried safe mode / disabled extensions, private browsing, heck I even did a clean re-install of Firefox and a different browser that isn't Firefox. All before I came here and posted a request for help.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Chosen Solution

Sorry, I've missed some parts of your above post about what you've tried so far.

Did you try to disable the Firefox Password Manager?

  • Tools > Options > Security: Passwords: [] "Remember passwords for sites"

Such issues can also happen if there are multiple entries (possibly with a blank name) in the Password Manager.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

Modified by cor-el

Question owner

Apology accepted and thank you for taking a second look at my post and your new suggestions.

Apparently the culprit is the file "places.sqlite".

I did as you suggested and created a new profile and it worked. Then I followed the instructions in your last link about transferring data between profiles and it broke again. After that I created a third profile and copied only one file at a time from the list of files to transfer, until the problem showed up again. Which happened after I copied over "places.sqlite". (Of course it was a file towards the very end of the list.)

What confuses me now is this: in my original attempts to fix the issue I made sure to start out with a new and clean profile and then copied over only the folders "adblockplus" and "searchplugins" and imported my bookmarks from a back up file.

How did that corrupt the "places.sqlite" in the new profile? I admit I've no knowledge of the inner works of Firefox, I just made sure to search the 'net for a solution before I gave up and came here and now I'm asking mostly so I've a chance of preventing the problem from recurring.

(Also, please understand that it's very frustrating if after having spent way too much time trying to fix a simple log in problem, you finally give up and make a help request. Then you try to be as detailed as possible in order to make it easier for whoever takes the time to help you... only to get what looks like a standard copy&paste reply that just repeats to you all that you've already done.)

Thank you.

ETA: importing my bookmarks recreates the problem, which I'm guessing you already knew, with whatever the connection is between bookmarks and the "places.sqlite" file. Any suggestions on how I can import my bookmarks without having to add every single one by hand just so I can log in at add-ons.mozilla.com?

Modified by eviljy