X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox freezes windows 8

Posted

Since installing windows 8 firefox keeps freezing. I waited to install FF17 but even that freezes the very same way.

  • The only way I have found to solve it is to restart the computer and once in a while it fixes the issue till the next restart when the same happens again.
  • I have used FF for long and never saw this till I installed Windows 8 Pro few days ago.
  • I opened FF in safemode and the exact same happens so I guess this is not an add-on problem.
  • I reseted my FF and same problem is there.
  • After resetting, I opened FF in safemode, and still problem is there.
  • This happens when I open a webpage (most pages but not all), and after a long freeze FF says "Unresponsive script" and depending on the webpage gives a line, for example this when I tried to open www.BBCpersian.com:

Script: http://node1.bbcimg.co.uk/glow/glow/1.7.3/core/core.js:19

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11

More Information

Application Basics
Name
Firefox
Version
17.0
User Agent
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adobe Acrobat - Create PDF
1.2
false
web2pdfextension@web2pdf.adobedotcom
DigitalPersona Extension
5.0.0.4248
false
otis@digitalpersona.com
DivX Plus Web Player HTML5 <video>
2.1.2.145
false
{23fcfd51-4958-4f00-80a3-ae97e717ed8b}
Norton Identity Safe Toolbar
2013.2.2.2
false
{F04D2D30-776C-4d02-8627-8E4385ECA58D}
Norton Vulnerability Protection
11.1.1.5 - 3
false
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
extensions.lastAppVersion
17.0
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
toolkit.startup.recent_crashes
1
Graphics
Adapter Description
AMD Radeon HD 6500M/5600/5700 Series
Vendor ID
0x1002
Device ID
0x68c1
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
9.2.0.0
Driver Date
9-27-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.2.9200.16433)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (AMD Radeon HD 6500M/5600/5700 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Try to disable some settings in the Properties > Compatibility tab of the Firefox desktop shortcut.

  • disable visual themes
  • disable desktop composition
  • disable display scaling on high DPI settings

Question owner

In Compatibility tab, I can see the "disable display scaling on high DPI settings" option, where are the other two?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Maybe the other only apply if Aero is enabled.

See:

Question owner

I checked these and none of them solved the issue: 1. "disable display scaling on high DPI settings" option 2. Run under comparability with Windows 7 3. Run under comparability with Windows Vista

What else can I do?

should I assume that Mozilla knows of this incompatibility issue between FF17 (same with FF16.0.2) and Windows 8 Pro? Is anyone working on this?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

So should I assume that Mozilla is aware of this incompatibility between FF17 and Windows 8 Pro?

drhaze 0 solutions 2 answers

My firefox 17.01 with flash player 11.5.502..110 and windows 8 Pro x64 with Bitdefender 2013 hangs all day log. go to amazon and it hangs. task manager no cpu usage. kill process use chrome or oper or ie. but no firefox. i wish i could use my favorite firefox.

ceiswyn 0 solutions 1 answers

Helpful Reply

For the record, Firefox worked perfectly for me on Windows 8 initially, but became unusable after I installed my first Windows 8 update. (Which I didn't want but couldn't refuse, but that's a whole nother rant)

purevw 1 solutions 24 answers

Helpful Reply

For what it's worth, I have found that if you run Firefox in administrator mode, it does not freeze. Apparently there is a permission problem in Firefox or the flash plugin?

tr4np 0 solutions 2 answers

I finally figured out why mine was freezing! I ran it in Safe Mode (selected Help -> "Restart with Add-ons disabled") and noticed that the freezing did not occur any more. I know the original poster already tried Safe Mode, but this may help others who have not bothered to try Safe Mode.

After re-enabling my add-ons one at a time, I discovered that the GreaseMonkey extension was causing the freezes. I uninstalled GreaseMonkey, and now Firefox no longer freezes. :)

purevw 1 solutions 24 answers

That is exactly how it should be done. If an add-on or plug-in is causing problems, that is the only good way to pinpoint which it is. Sadly, many are not patient enough to do that.

In my case, flash seems to be the culprit. Since it doesn't seem to affect everyone, I assume my real problem lies somewhere within Windows or Flashplayer rather than Firefox and is probably related to permissions and / or configuration. Google Chrome also seems to misbehave on web pages with a lot of flash content in Windows 8 on my machines.

Running the programs as administrator is not a solution. It is a real security risk. Microsoft wants everyone to use IE, so it is not surprising that using a "foreign" browser, as they might put it, would cause difficulties.

I believe that Mozilla is making progress. I am using Aurora, the Alpha (unstable) version of what will be a future Firefox, and there is still a problem with Flashplayer, but at least it doesn't completely hang like the current Firefox does. It simply won't load the videos correctly most of the time. It does work on occasion, though. A step in the right direction.

tobe81cwb 0 solutions 2 answers

The same thing on mine. But all suggestions had no success. turning off the visual effects not resolved Starting in safe mode also had no effect. Firefox has no add-in (installed firefox less than 20 mins ago). The strange thing is that firefox always freeze on the same sites, so do not believe is something random.

purevw 1 solutions 24 answers

Most likely the sites in question all run flash content. It's not something that you should do for normal use, but have you tried running firefox as an administrator? It eliminates the freezing for me, but becaus eof the risks involved, it should only be used just for verification and troubleshooting; not for browsing.

tobe81cwb 0 solutions 2 answers

I've tried running as administrator, but Firefox keeps freezing.

And I believe that the problem is not flash, but some javascript, because the sites of Adobe Flash, Youtube and other sites that use Flash function normally.

But what is more strange is that from yesterday to today, Firefox started to function normally, and the pages that were freezing Firefox, are functioning without any modification in the options (the computer have nothing installed, only Windows 8 + Drivers + Firefox + Chrome (because Firefox was crashing)).

I have no explanation for what happened, I just know that now is functioning normally.

FroFro 0 solutions 1 answers

try installing Java. doesn't slow down or freeze at all now.

http://www.java.com/