X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

A lot of addons are not compatible with latest versiosn of Firefox! It has become unbearable!

Posted

I have just updated to Firefox 17; I have used it back from version 3, and I feel it's time to say goodbye to Mozilla Firefox!

I have used a lot of other programs, and I don't think there is any other program that updates as frequently as Firefox - every couple of months there is a new version!

It's not bad thing itself, but very, very bad thing is that, each time I update Firefox, one third of my plugins and addons are not compatible with new version! That completely ruins my joy of surfing the internet; since updating from Firefox 14 to current Firefox 17, I have lost at least five addons that were very important for me; the last one, now, is Tab Mix Plus, it's not compatible with Firefox 17, and my Firefox now looks completely different from what I'm used to, I cannot use it!

This has become unbearable any longer: I cannot cope with constant updates of program and addons, and finding replacements for addons that became incompatible! I want to browse internet, and not always to maintain something within Firefox!

You offered me some half of dozen years of excellent experience of browsing the web, but you've become too user enemy for my liking; , so bye, bye, Firefox!

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Google Update
  • GEPlugin
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Jan. 9 solutions 82 answers

If add-ons are so important to you, remember to check for add-on compatibility before upgrading. (See image below)

Bookmark your add-ons pages (addons.mozilla.org) and check their compatibility before upgrading Firefox. The other option is to Install an older version of Firefox compatible with your add-ons.

Also read:

Keep in mind that other browsers have updates too, which may or may not break their add-on compatibility.

Modified by Jan.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can install the latest Dev-Build of Tab Mix Plus.
Note that by doing that you will switch on the development update channel and will have to install the latest release via the Add-ons site to return to the regular updates.

See the sticky on the Tab Mix Plus forum: