X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Constant JavaScript 'Syntax error' notification after upgrading to 17.0

Posted

Almost at every page I open appears following notification 'Error: Syntax error' from JavaScript application. Even on this page where I fill the form. I have to click 'OK' several times to make it disappear.

Chosen solution

Same issue with latest upgrade. In Safe Mode removed SocialFixer. That fixed the problem.

Read this answer in context 33

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • VLC media player Web Plugin 2.0.2
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Provides additional functionality on Facebook. See our web site for details.
  • Version 1.0.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • iTunes Detector Plug-in
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

nogueira13 0 solutions 3 answers

I don't know what is this App the "google social fixer". Where can I download it from where?

Edzzed 0 solutions 2 answers

http://socialfixer.com/ just choose the browser you use and it'll download the application

Modified by Edzzed

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You only get this 'Error: Syntax error' from JavaScript application notification if you have an extension installed that isn't working properly and is responsible for this error.
There is no need to install an extension.

Other extensions may be causing a similar error to appear, so check that if you do not have the Social Fixer extension.

esweb 0 solutions 2 answers

I had an gmail third-party extension that caused the Javascript syntax error. This is how I tracked it down in amongst all the other addons. 1. Go Start and enter Run. 2. Enter -firefox -same-mode. 3. On the dialog box displayed, click OK and Firefox will start in Safe Mode. 4. Check if the problem has disappeared. 5. If not, in Firefox go Tools > Options. . 6. On the General tab, click the Manage Add-Ons. 7. Disable all the add-ons, restart Firefox to see if problem fixed (in my case it did not fix the problem. If the problem has been fixed, progressively enable the add-ons until you find which one caused the problem. 8. On the window displayed when you click Manage Add-Ons, select Extensions in the left-hand menu. 9. Do as above and disable all the extensions. 10. My guess is that the problem should now have disappeared. 11. Finally, progressively enable 2-3 extension until you have isolated which one has caused the problem.

IMPORTANT. After each enable/disable operation, you needto restart Firefox.

MaryXYX 0 solutions 6 answers

I've recently started having this problem on a system which does not have Social Fixer. What is the difference between restarting in Safe Mode and disabling add-ons? If I restart in Safe Mode I don't have the problem, but if I disable all add-ons I still do.

How do you re-enable add-ons in Safe Mode? As I understand it, all add-ons are completely disabled until the next restart.

MaryXYX 0 solutions 6 answers

Just to add an extra detail. I still get just as many Java Script errors if I disable Java Script.

esweb 0 solutions 2 answers

@Maryxxx. Hopefully, I am sure Mozilla support will answer your question better than I can. My understanding is that Safe Mode only prevails for your current session. If you restart Firefox, it starts in normal mode.

If you still have the problem after disabling all the add-ons, I suggest you also disable the Extensions as I described in my earlier post. This is how I was able to isolate which extension caused the problem.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

If you disable JavaScript via "Firefox > Options" then that only effect JavaScript used on web pages, but it has no effect on extensions and internal Firefox JavaScript files.

You will have to click the Disable button next to each extension on the Tools > Add-ons > Extensions (about:addons) page and close and restart Firefox.


If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

MaryXYX 0 solutions 6 answers

"Disable JavaScript only affects web pages". OK, got it now - that isn't clear from the options/add-ons/plugins pages. I might have forgotten to restart on some occasions too.

Upgrading Social Fixer from 6.6 to 7.3 seems to have solved the problem on all VMs and hardware systems that have Social Fixer on them. If I can reproduce the problem on a VM without it I'll go one add-on or plugin at a time and try to find another culprit.

Postscript: I have not been able to demonstrate another culprit, so I'll stick with the "Social Fixer v6" explanation.

Modified by MaryXYX

yrt8476 0 solutions 1 answers

I had this problem on 17.x and 18.0; adblock plus didn't seem to be the problem, since alternately enabling and disabling everything for FB didn't help.

Per the advice elsewhere on this thread, updating Social Fixer (which wasn't showing up at all on FB, so I had assumed that I'd already disabled it on this laptop and it couldn't be the problem) solved the problem. You can find the most current version at http://socialfixer.com/ .