Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Donate link for Firefox add-ons not working

  • 4 replies
  • 2 have this problem
  • Last reply by cheroz

more options

I've added a few Firefox add-ons since upgrading to Firefox 16.0.2 and would like to donate. However, the donate links which re-direct to paypal are not working for me (the donate links that redirect to the developers personal website do work, however). After trying to re-direct to paypal, it doesn't succeed and then turns the webpage a transparent grey, with the Firefox webpage visible underneath. Before upgrading to Firefox 16x, I was running Firefox 8x with Flash Player 10x (with Windows XP sp3), and the donate link worked fine. It should be noted that I am running Flash Player 10.3x because I also have the Real Player Download plug-in which is incompatible with Flash Player 11x. I've disabled other add-ons which might be causing a conflict (like Adblock plus and Real Player Download), and have enabled pop-up windows in Firefox options, but the donate link still doesn't work. I think my only option is to upgrade Flash Player 11x (which then I would have to downgrade after donating if I want the Real Player Download plug-in to work). Anyone else experiencing this problem?

All Replies (4)

more options

can you provide your addon link?

more options

This is the add-on link. Firefox won't open to allow me to make contribution

more options

hey cheroz, please create a new topic and ask question, also which version of Firefox do you have?

more options

I'm using version 20.0.1. which, I understand, is the latest incarnation of FF.

I wanted to donate some $ to a developer for an add-on. When I'm prompted to pay by PayPal via the donate link provided by Firefox, there is a bit of a hesitation then the screen darkens and the Paypal link doesn't open nor am I led to the developer's website. Nada. I believe the same problem was being experienced by "oabreichenbach" in the previous posting.