X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do i go back to the older version of firefox? 17.0 has lost all my tabs, i want my tabs back.

Posted

there are no compatible versions of my add ons or extensions and i have lost a boat load of tabs i had saved and i want them back so i want to go back to the previous version of firefox...i now have the new 17.0 and not happy i lost all my info and settings

Chosen solution

u dont have to uninstall firefox...

google old version Firefox....u should get a link from ftp.mozilla.org website...download the version u want...probly the most current old version will work for you...then...and this is important...disconnect from the internet before u install the old version or firefox will automatically upgrade ur installation to FF 17...install the old version right on top of whatever u have now (17 or whatever)

after u are installed, go ahead and connect back to the internet...

i just downgraded from FF 17 to FF 16 like this, bc i lost Tab Mix Plus and thats th only way firefox tabs work...

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • npmnqmp 989898989877
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • 1.7.0059.1
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Jan. 9 solutions 82 answers

Helpful Reply

Hi,

Follow these steps:

  1. Uninstall Firefox from your computer
  2. Install an older version of Firefox

Modified by Jan.

desertvoice 1 solutions 3 answers

Chosen Solution

u dont have to uninstall firefox...

google old version Firefox....u should get a link from ftp.mozilla.org website...download the version u want...probly the most current old version will work for you...then...and this is important...disconnect from the internet before u install the old version or firefox will automatically upgrade ur installation to FF 17...install the old version right on top of whatever u have now (17 or whatever)

after u are installed, go ahead and connect back to the internet...

i just downgraded from FF 17 to FF 16 like this, bc i lost Tab Mix Plus and thats th only way firefox tabs work...

Modified by James

thesurfer 0 solutions 1 answers

Thanks also. I have tried again and again to re-install a lower version of Firefox and it didn't work until I disconnected from the Internet.

Now to figure out why LassPass doesn't want to install like on all Chrome and IE...

desertvoice 1 solutions 3 answers

glad it worked fa u...noticed they changed the link put in my first reply here to a different link than the one i submitted...the link i added was to old apps dot com, without spaces...dont know why they changed th link to one of theirs...anyway...glad it worked...as long as u connected to th net, auto update gonna kick in and u be gonna go round tht mountan forever...lololol

cant help u about lasspass cuz i never heard of it and i dont use chrome or IE...

hope u find ur answers... -g-

Question owner

thank you to all...i found older version, just downloaded, didnt shut off internet or nothing....and my good ole version came back...hasnt tried to go back to 17 as of yet and no problems!