X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Font is messed up on Firefox 17.0

Posted

Just updated to FF17.0 and the fonts look awful, something like when the ClearType is enabled in Windows. I have ClearType disabled cause I hate the look of the fonts with it enabled, and now Firefox looks like it's all over it. Font is like bolded. What happened? Can I disable it somewhere in Firefox?

Chosen solution

Hey guys! Thanks to everyone who helped us in troubleshooting this. We are fairly certain it's an azure problem. There is a patch in the works and setting gfx.content.azure.enabled = False seems to work in the meantime. I don't know if the patch will be part of a chemspill or wait until 18. Thanks for your help and patience.

Happy Thanksgiving!

Read this answer in context 17

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated to Firefox 17.0

Installed Plug-ins

  • 2.1.2
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.2 r202
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • 0.70.4
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Informacje o aplikacji
Nazwa
Firefox
Wersja
17.0
Identyfikator programu
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Folder profilu
Pokaż folder
Włączone wtyczki
about:plugins
Konfiguracja kompilacji
about:buildconfig
Zgłoszenia awarii
about:crashes
Zużycie pamięci
about:memory
Rozszerzenia
Nazwa
Wersja
Włączone
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
ColorfulTabs
17.1
true
{0545b830-f0aa-4d7e-8820-50a4629a56fe}
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Ważne zmodyfikowane ustawienia
Nazwa
Wartość
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
524288
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.display.background_color
#C0C0C0
browser.display.use_system_colors
true
browser.history_expire_days.mirror
2
browser.history_expire_days_min
2
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
4
browser.places.updateRecentTagsUri
false
browser.privatebrowsing.dont_prompt_on_enter
true
browser.search.useDBForOrder
true
browser.sessionstore.restore_on_demand
false
browser.startup.homepage
http://www.onet.pl/
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
browser.tabs.loadInBackground
false
extensions.lastAppVersion
17.0
font.internaluseonly.changed
false
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1353270609
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
places.last_vacuum
1296324654
plugin.disable_full_page_plugin_for_types
print.print_printer
Microsoft XPS Document Writer
print.printer_HP_LaserJet_1022.print_bgcolor
false
print.printer_HP_LaserJet_1022.print_bgimages
false
print.printer_HP_LaserJet_1022.print_command
print.printer_HP_LaserJet_1022.print_downloadfonts
false
print.printer_HP_LaserJet_1022.print_edge_bottom
0
print.printer_HP_LaserJet_1022.print_edge_left
0
print.printer_HP_LaserJet_1022.print_edge_right
0
print.printer_HP_LaserJet_1022.print_edge_top
0
print.printer_HP_LaserJet_1022.print_evenpages
true
print.printer_HP_LaserJet_1022.print_footercenter
print.printer_HP_LaserJet_1022.print_footerleft
&PT
print.printer_HP_LaserJet_1022.print_footerright
&D
print.printer_HP_LaserJet_1022.print_headercenter
print.printer_HP_LaserJet_1022.print_headerleft
&T
print.printer_HP_LaserJet_1022.print_headerright
&U
print.printer_HP_LaserJet_1022.print_in_color
true
print.printer_HP_LaserJet_1022.print_margin_bottom
0.5
print.printer_HP_LaserJet_1022.print_margin_left
0.5
print.printer_HP_LaserJet_1022.print_margin_right
0.5
print.printer_HP_LaserJet_1022.print_margin_top
0.5
print.printer_HP_LaserJet_1022.print_oddpages
true
print.printer_HP_LaserJet_1022.print_orientation
0
print.printer_HP_LaserJet_1022.print_pagedelay
500
print.printer_HP_LaserJet_1022.print_paper_data
9
print.printer_HP_LaserJet_1022.print_paper_height
11,00
print.printer_HP_LaserJet_1022.print_paper_size_type
0
print.printer_HP_LaserJet_1022.print_paper_size_unit
1
print.printer_HP_LaserJet_1022.print_paper_width
8,50
print.printer_HP_LaserJet_1022.print_reversed
false
print.printer_HP_LaserJet_1022.print_scaling
0,50
print.printer_HP_LaserJet_1022.print_shrink_to_fit
true
print.printer_HP_LaserJet_1022.print_to_file
false
print.printer_HP_LaserJet_1022.print_unwriteable_margin_bottom
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_left
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_right
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_top
0
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_page_delay
50
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
9
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11,00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8,50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1,00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.downloads
false
privacy.clearOnShutdown.formdata
false
privacy.clearOnShutdown.history
false
privacy.clearOnShutdown.offlineApps
true
privacy.cpd.cookies
false
privacy.cpd.sessions
false
privacy.donottrackheader.enabled
true
privacy.item.downloads
false
privacy.item.formdata
false
privacy.item.history
false
privacy.item.offlineApps
true
privacy.item.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
security.warn_viewing_mixed.show_once
false
Grafika
Opis adaptera
NVIDIA GeForce GTX 560 Ti
ID dostawcy
0x10de
ID urządzenia
0x1200
RAM adaptera
1023
Sterowniki adaptera
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Wersja sterownika
9.18.13.697
Data sterownika
10-2-2012
Włączone Direct2D
true
Włączone DirectWrite
true (6.1.7601.17789)
Parametry ClearType
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
Renderer WebGL
Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
Okna ze sprzętowym przyspieszeniem grafiki
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Przyrostowy GC
1
Ułatwienia dostępu
Aktywne
0
Zablokuj ułatwienia dostępu
0
Wersje bibliotek
Oczekiwana wersja minimalna
Wersja w użyciu
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

Vadauco 0 solutions 2 answers

I just upgraded to v18. Never had this issue before with v17... now the fonts are giving me eye strain, because they look very blurry. This is really bad. I tried the azure/direct2d/acceleration fixes, but none of them worked.

I simply cannot continue using Firefox if it gives me headaches within 10 minutes of reading... I'm downgrading to v17 until this is fixed. Hopefully soon.

StratMan55 0 solutions 8 answers

Vadauco, thanks for the validating reply as I totally agree on the blurry text eye strain BUG in FF18 as show in my two screen shots at the bottom of Page 4.

FF-DevTeam, like other users have posted above, please know that I, too, have:

1) Disabled the Win7 ClearType feature when the OS was first installed the other week prior to upgrading from FF17 to FF18;

2) Have set gfx.content.azure.enabled = False; and,

3) Have set gfx.direct2d.disabled = True.

Unfortunately, none of those ideas resolved the issue that did not exist in FF17 prior to updating the other day.

Therefore, I just finished restoring the pre-FF18 Acronis backup image with FF17.0.1 to the disk and this FF18 fuzzy text display bug NO longer exists. :)

Like Vadauco, I'm gonna stick with FF17 until this ongoing bug issue is resolved, once and for all.

Sure would appreciate your reply back on this. Thanks so very much.

Bill, Database Software Engineer... Without much HTML / CSS expertise. :)

Modified by StratMan55

StratMan55 0 solutions 8 answers

Fellow Users and FF-DevTeam:

Please keep in mind that I do not have much HTML~CSS nor hardware expertise as I'm a software database tech and am a 2-week old FF rookie.

In follow up to my previous posts and restoring the disk back to the Jan 8th image in order to "rollback" to FF17, I just stumbled into a possible cause of this fuzzy text display "bug" while confirming all prior FF17 User Preference Settings in this new Win7-64 custom installation build on an Intel i7 Chip & MBoard that was not "seen" before herein nor was it known to look for...

In the Tools / Options / Advanced / General Tab, it was noticed that the FF17 install had the "Use Hardware Acceleration When Available" box checked, which was not recalled being checked when configuring FF18 yesterday. For grins, I unchecked the box, stopped and restarted FF17 and, sure enough, the blasted fuzzy text problem instantly returned. Upon rechecking that config setting box and restarting FF17, the fuzzy text issue went away.

Until FF-DevTeam and/or other users please kindly confirm this finding, FF17 will continue to be used just in case something else is going on "under the hood."

Hope this helps and sure would appreciate your feedback on this.

Thanks so much.

Dancorg 0 solutions 1 answers

i'm finding this issue in Linux Mint: FF 18.0 Linux Mint 12 ATI HD4870, proprietary drivers

Disabling hardware acceleration doesn't fix the problem

squatchy 0 solutions 1 answers

I'm having the problem too. Didn't exist on FF17. I had hardware acceleration disabled, but I tried enabling it and it didn't make a difference. I'm back to using it disabled and still the same thing. I'm using XP on a laptop with Intel X3100 integrated graphics.

latimer 0 solutions 4 answers

Just upgraded from FF esr 10 to esr 17 and got the same problem.

I am on w7 64 with an ATI Radeon HD2400 Pro.

Setting gfx.direct2d.disabled = True brought some relief but the font still is not as good as it was with esr 10.

I'm glad I found the fix though because without it the blurry font I got with direct2d enabled would have made me revert to esr 10.

I wonder why even after more than 2 months since this font problem has been reported there is still no real fix for it.

alulaq2 0 solutions 1 answers

I am using Firefox 18 on an HP (Pavilion dv6) laptop, on Windows 7 Professional. This DEGRADED FONT issue is NOT resolved by ANY of the "fixes" offered above. I have tried them all: changing gfx.direct2d.disabled to true; turning off hardware acceleration; ETC. This is an issue that should be DEFINITIVELY DEALT WITH by the Mozilla development team. leaving this to "...try this, try that.." approach is unacceptable. This is an issue that affects millions of users. "Trying" to fix the problem by changing some about:config settings is not the answer. If someone has a DEFINITIVE, TESTED SOLUTION, I'd sure like to know what it is.

Vadauco 0 solutions 2 answers

Hey dude, can't say it's really a fix, but I started using Pale Moon and things just got a lot better. Firefox is becoming all messed up.

StratMan55 0 solutions 8 answers

02/16/2013 at 12:30 PM: alulaq2 said:

"This DEGRADED FONT issue is NOT resolved by ANY of the "fixes" offered above. I have tried them all: changing gfx.direct2d.disabled to true; turning off hardware acceleration; ETC. This is an issue that should be DEFINITIVELY DEALT WITH by the Mozilla development team. leaving this to "...try this, try that.." approach is unacceptable. This is an issue that affects millions of users. "Trying" to fix the problem by changing some about:config settings is not the answer. If someone has a DEFINITIVE, TESTED SOLUTION, I'd sure like to know what it is."

TOTALLY AGREE! This topic is now on page 5 going back to November 2012. Many users have contributed excellent comments on what they have tried to do to resolve this... TO NO AVAIL!

Frankly, the failure of the Mozilla DevTeam to resolve this bug for over 3.5 months does not align with Mozilla's outstanding, worldwide browser reputation.

What's up with that?

Why won't you respond back to your dedicated users who have taken the time to assist you with your "offsite, QA testing?"

Respectfully,

Bill, CRM/ERP Database Engineer

abezza 0 solutions 6 answers

Resetting Firefox seems to have fixed the issue for me. Note, I experienced the issue even in FF19 (at least until i reset Firefox).

To reset Firefox go to Help -> Troubleshooting Information -> Reset Firefox.

Prior to resetting Firefox the issue appeared to be triggered on my system from version 17 when:

1) hardware acceleration was enabled; and, 2) the bookmarks side bar was open.

Modified by abezza

gavsiu 0 solutions 3 answers

Is this the same issue as what I'm experiencing? I get pixelated text when I visit a page or scroll around. Hovering over links or scrolling content out of view fixes it temporarily.

It seemed to happen after I updated my Windows 7 recently. Turning off hardware acceleration in Firefox makes it stop, but I want it on.

Firefox 19 and Windows 7 x64 SP1

Modified by gavsiu

abezza 0 solutions 6 answers

Yes this sounds like the same issue I experienced. Resetting Firefox seemed to rid this problem mostly for me. It has occurred again once on a particular random web that I visited.

The other web pages that I frequented regularly that were problematic seem to be ok after resetting Firefox for me.

denbkh 0 solutions 1 answers

I had a similar problem and using this settings i fixed it:

  • gfx.downloadable_fonts.enabled = false
  • gfx.direct2d.disabled = true

You can set this values in "about:config" page

Modified by denbkh

radlmayer 0 solutions 3 answers

@denbkh - gfx.downloadable_fonts.enabled = false - this solved the fonts problem in my case. thx

gavsiu 0 solutions 3 answers

Does gfx.downloadable_fonts.enabled deal with @font-face? Are web fonts the cause of the pixelation?

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

There is usually no need to disable downloadable fonts by setting gfx.downloadable_fonts.enabled=false and disable fonts downloaded via @font-face rules.

You can try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

radlmayer 0 solutions 3 answers

The direct2d setting made all my fonts in firefox crappy (before it was just in webpages and afterwards even the font in the tabs was bad)...

But I'm kinda unsure about it all, because I do have NoScript installed and this can block fonts as well... So I guess there ain't one right solution for everyone. Just for me the downloadable_fonts switch was doing the trick.

radlmayer 0 solutions 3 answers

@gavisu: And yes it seems to deal with @font-face, because after i disabled it in mozilla, NoScript didn't have to block it anymore -> @font-face was previously blocked my firefox (at least imho).

ricktay 0 solutions 5 answers

I replied in another thread but this might be more active for responses.

I have a win7, i7 first gen on an HP and this blurry font issue started about a ten days or so ago when I let Firefox auto update me to v 19.0.2.

So far it has only happened on Google sites, especially google news. The fonts load clear, but when I (edit) mouse over a news story the text blurs. Selecting the text in the news stories temporarily fixes the blurred fonts, but the blurring starts up again as I mouse over any stories again.

As I mentioned in the other thread, I installed a new Epson printer about the same time this blurred font issue popped up and thought maybe some of the OCR or other software installed with the printer caused the problem. But these forums indicate it is widespread, so it may not be the Epson software after all.

I have only seen this on Google sites, and it will do it every time on the Google news page.

Updated: I tried to use the snipping tool to post a picture here, but I have discovered that activating the snipping tools fixes the blurred fonts much like selecting the text does!!!! For the attached image of the blurred fonts I had to use the print screen method to capture the image.

Note that I did not mouse over the first two stories in the image and the fonts are clear, but the others blurred when I moved the cursor over them!

Modified by ricktay

PaulusGrandis 0 solutions 1 answers

ricktay's screen shot sums it up. Firefox font rendering is completely broken, making the browser completely unusable.

https://support.cdn.mozilla.net/media/uploads/images/2013-03-09-19-04-19-408a7f.png