Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

What causes webfonts to not display on my FX profile?

  • 4 replies
  • 1 has this problem
  • 27 views
  • Last reply by kelvinsong

more options

For some reason, under my FX profile, webfont specimens on sites like http://www.fonts.com/font/itc/itc-franklin-gothic?QueryFontType=Web#product_top or http://www.linotype.com/1129914/ClassicGrotesque-family.html fail to display, and instead show my default Firefox font. Starting Firefox in Safe Mode doesn't solve the problem, nor does changing my default Firefox fonts back to "serif" and "sans-serif", etc. Running Firefox with a new profile does solve the problem though. What causes this problem? I don't want to start with a new profile and lose all my bookmarks, addons, settings, etc.

All Replies (4)

more options

Is downloadable fonts enabled?

You can check the gfx.downloadable_fonts.enabled pref(s) on the about:config page.

You can also try to reset all preferences by (temporarily) renaming or moving the prefs.js file to see if that helps.

more options

Downloadable fonts is enabled— didn't fix. I tried resetting the preferences, it worked! Now how do I find out which preference is specifically causing the problem?

more options

You can try to sort by user set on the about:config page (click the status header) to make it easier to spot modified prefs and start with looking at font related prefs to see if anything springs out.

more options

Found the problem— It was that the "send referrer header" was turned off.