X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I remove Yahoo as a search engine for wrong written URLs?

Posted

I installed some plugin which put Yahoo as my default search engine. Meanwhile I could remove most of it and I am able to use Ixquick again. But when I enter a wrong URL into the url bar, e. g. motsilla.org, it still takes me to the Yahoo search! How can I remove this? I've seen nothing in the about:config.

Chosen solution

Got it! It had nothing to do with the proxy settings, it was actually a software called "Panda Security". I hate programs like this. But thanks a lot for your effort!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • PDF-XChange Viewer Netscape Gecko Plugin
  • 4.1.10329.0
  • 2.1
  • PlayStation(R)Network Downloader Check Plug-in
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

In about:config, did you see anything listed for the keyword.URL preference? That usually specifies the search engine to use for address bar searches.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

See also:

Question owner

I know that entry, and I already changed it earlier. The issue only appears, when I enter a wrong URL. I have no idea how to fix it. Maybe there's an installed Plugin which I can't see?

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Plugins are mostly used to embed content in pages. Extensions are more likely to alter the UI behavior. You could check here:

orange Firefox button or classic Tools menu > Add-ons > Extensions category

If none seem obvious, a standard diagnostic to bypass interference by all extensions (and some custom settings) is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode."

If the URL bar works correctly, this points to one of your extensions or custom settings as the problem.

Any change?

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

By the way, some ISPs and DNS providers divert 404 messages to a search page, but this probably would be consistent between the browsers on your system and not limited to Firefox.

Question owner

No, nothing changed. Some weeks ago, still the default mozilla error page showed up, so I think I installed some strange software. Yahoo is also set as main page and default search engine in Chrome and IE. I'm now checking my software with CCleaner, hope it helps.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

You might want to check your proxy settings in IE. Firefox often uses those system default settings.

Chosen Solution

Got it! It had nothing to do with the proxy settings, it was actually a software called "Panda Security". I hate programs like this. But thanks a lot for your effort!

pjeyavel 0 solutions 1 answers

Well if the previous suggestions it doesn't work the kindly go to the installed directory path of fire fox for e.g "c:\Program Files\Mozilla Firefox\searchplugins" and remove/delete the xml files related to other search engine which you donot need. and Restart ur firefox.