X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

what level software on an imac is now supported by firefox

Posted

We have an IMAC withthe OSX level software, and was just told by Firefox that our IMAC was no longer supported. We still have access to the internet, etc, but all other coverages are not there (security, spam, etc). If we update our present software, what level would we need to go to, in order for Firefox to work properly? Thank you.

Chosen solution

newer firefox versions require at least mac osx 10.6: www.mozilla.org/en-US/firefox/17.0/system-requirements/

Read this answer in context 1

Additional System Details

This started when...

we opened our computer on Nov 14, 12.

Installed Plug-ins

  • Office Live Update v1.0
  • Facebook Video Calling by Skype
  • SOE Web Installer
  • Shockwave Flash 10.3 r183
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2045 solutions 8899 answers

Chosen Solution

newer firefox versions require at least mac osx 10.6: www.mozilla.org/en-US/firefox/17.0/system-requirements/