X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox doesn't work with Windows 8

Posted

I installed Windows 8 a couple of weeks ago and then downloaded Firefox. I've had problems getting pages to render properly, slow speed etc. IE10 seems to work fine. What's the issue?

Additional System Details

This happened

Every time Firefox opened

This started when...

Downloaded Windows 8

Installed Plug-ins

  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10757 solutions 96831 answers

Try to disable hardware acceleration in Firefox.

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Question owner

Interesting that security software is the problem. I had the same security software for the past 4 years with earlier versions of Firefox and it never caused a problem. I find it odd that now all of a sudden it's a problem. Sorry, but I don't buy it.

Pcobiwan 0 solutions 3 answers

Neither the disabling of hardware acceleration or resetting of security worked. It simply takes too much time to load pages not related to what I've requested. I ask for my email and it loads a background page on sports, etc.

Modified by Pcobiwan

Pcobiwan 0 solutions 3 answers

Found the answer in another part of the forums. Uninstall Firefox, but leave your personal information (bookmarks, etc.) Reinstall Firefox. That worked for me!

Modified by Pcobiwan