X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox always open with new tab and doesnt go to homepage, UNLESS I have it open then it opens a new browser and goes to my homepage

Posted

Instead of opening on my homepage, firefox opens on blank page, it says new tab. If I open it and open a second browser instance while the first is still open, the second instance will go to my home page as it should. I have tried reinstalling firefox.

Additional System Details

This happened

Every time Firefox opened

This started when...

it just started doing this

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Coupon Print Activator
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.1.10329.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp
  • Wacom Dynamic Link Library

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello markshiro, if i understand clearly, when you open the browser the only you can see is a blank page, and if you click a new tab(am i correct or a new window ?) then you see your home page.

the start page of the browser and the new tab is different.

see how to set the homepage when you start the browser: How to set the home page

and see how to set the new tab page : New Tab Page – show, hide and customize top sites

thank you

jp4120 0 solutions 1 answers

This is an annoying problem that Firefox should fix once and for all. I had fixed it on another computer running Firefox but couldn't remember so spent 2 hours trying all the suggestions which non worked. I have Google as my homepage, i want Google when I open a new tab...but bing kept opening as default in new tabs. so I disabled all the add-ons that seem to be cancelling each other out. 1. set homepage to Google via options...general 2. only enable new tab homepage 0.4.3 - 3. only other add-ons I enable are adblock plus 2.2.2, adblock plus pop-up addon 0.6

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6642 answers

jp please post a new question after you try Resetting Firefox Reset Firefox – easily fix most problems

nsmithduke 0 solutions 3 answers

This is exactly how to fix the problem.

New Tab Page – show, hide and customize top sites: https://support.mozilla.org/en-US/kb/new-tab-page-show-hide-and-customize-top-sites#w_how-do-i-turn-the-new-tab-page-off

Modified by nsmithduke

Question owner

Sorry but this didnt help. What happens is When I open firefox instead of going to my homepage which I set to Google.com via the options. It just opens a blank tab. Before if I opened firefox there was no tab unless I clicked on the little plus sign. It clearly states New Tab on the first thing when opened.I tried the

New Tab Page – show, hide and customize top sites: https://support.mozilla.org/en-US/kb/new-tab-page-show-hide-and-customize-top-sites#w_how-do-i-turn-the-new-tab-page-off. Did exactly as told but when I turn on firefox, same old thing. Now the weird part is if I open firefox I get what I just described, it opens with a blank new tab. But if I leave that instance open and open a 2nd browser, it opens to Google and looks fine! Very irritating . Also If I change the home page to Firefox homepage it works fine everytime. Seems they only want me going to thier page.
nsmithduke 0 solutions 3 answers

Strange. I followed the instructions exactly but, I used my home page which was Google News. Worked perfectly.

nsmithduke 0 solutions 3 answers

Worked for me and my home page is set to Google news. Yes, it is strange. I'm sorry this didn't work for you.

Question owner

I found a cure. I dont know what caused it but at least I know the solution, I read an article about resetting Firefox. I did and its back to normal now. Weird. Thanks for the help man, I appreciate it. :)

Question owner

I found a cure. I dont know what caused it but at least I know the solution, I read an article about resetting Firefox. I did and its back to normal now. Weird. Thanks for the help man, I appreciate it. :) I pasted this under question...Arrggh!