X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My Mac is incapable of running Mountain Lion, so can I go to 10 X 6 and use Firefox?

Posted

I really like Firefox and want to continue using it - can I go to OS 10 x 6 or 7 and still be supported? Unless someone wants to suggest another browser for 10 X 5......

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0
  • Facebook Video Calling by Skype
  • RealPlayer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

ideato
  • Top 25 Contributor
617 solutions 4264 answers

Hello thomkallor, of course and the better is to go to 10.7 if you can, see Firefox 17 System Requirements (Firefox 17 is in beta now).

thank you