X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do i remove ask search from firefox? The old answer was to reset the network.url string but i cannot highlight the reset tab to be able to use it.

Posted

This has already been answered in its first instance but my problem is that i cannot use the reset tab at the last step of the procedure, which is to reset the 'keyword.url' string. No tab, no reset, back to square one.

It's like Ask has gone one step further to look after itself...

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • NPWLPG
  • Logitech Device Detection
  • Garmin Communicator Plug-In 2.6.3.0
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

See Disable or remove Add-ons for information about removing a specific extension.
If your search results are still captured after AVG extensions are disabled, you will need to reset keyword.url in Firefox's advanced configuration:
Select Firefox's location bar (press CTRL+L or click it)
Type about:config and press enter
Click I'll be careful, I promise!
in the Filter box, type keyword.url
Right click the keyword.url preference below and choose Reset
The last step^^^, my reset tab is faded out and does not take a mouse click.
How do i fix this?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

That pref only works for searches via the location bar.
If that pref already has the default value then you can't reset it.

Where or when do you get ask.com ?


If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Question owner

Thankyou. My home page had been changed as it turned out and i hadn't noticed, when the last FF update came thru i presume. I didn't notice i think due to the way Google changes its look almost every day [Google is my usual HP] I did manage to also get rid of the Ask toolbar that was sitting in line with the address bar so that was a good thing too. Not happy about the way Ask installed itself, i loathe software that sneaks in even if it is supposedly safe to use. Cheers.