Question

Firefox will not load Java in Linux - even after following all instructions on net I can find - what am I doing wrong??

The problem I've got is I'm currently running Puppy Linux on my laptop.

Now I've tried everything I can to get Java working under either Firefox, Chromium or Seamonkey (I have all three browsers on my computer).

For firefox and seamonkey I have tried the following -

downloaded the tar.gz file for java unpacked it to /opt/java gone to /user/lib/mozilla/plugins and run the command ln -s /opt/java/plugin/i386/ns7/libjavaplugin_oji.so to create the symbolic link to the plugin checked that the plugin is executable (actually even tried giving everything full permission to read/write and execute it)

For Chromium done a similar thing but put the symbolic link in /usr/lib/chrome-linux/plugins folder instead.

Restarted the web browser, even tried restarting X Server in case the browser is running somewhere in the background.

All three browsers can pick up all the other .so plugins in that folder except Java.

When I click check plugins on firefox I get to the page about "Missing Java? - For your safety Firefox has disabled your outdated version of Java. Please upgrade to the latest version".

However the version I've downloaded is Version 7 Update 9 which is exactly the same one that is available as the latest version from Java themselves (it was only downloaded from that link a couple of minutes before, I've even tried re-downloading it just in case there has been an update within those 5 minutes).

If I go into the Java folder and run ControlPanel the Java control panel pops up and it knows where Java is installed and everything.

So what on earth is going on? Am I installing the plugin in the right directory? I'm guessing so as that is where all the other plugins are stored and Firefox, Chrome and Seamonkey are picking all the others up fine, or could there be an older version of Java lurking around somewhere on my system that Firefox, Seamonkey and Chrome are all trying to use?

I've also tried downloading the RPM and installing that into the /usr/java folder and replacing the symlink from /opt/java to the one in the /usr/java folder and still nothing.

I just really can't understand it 'cos it's picking up all the other plugins like Gecko and even installed Flash in the same way and that works fine.

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • solution
  • owner