X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox no longer supports your operating version and will be vulnerable to online attacks

Posted

Hey Firefox,

Long time user, first time writer. Lately, apropos of nothing, I've been getting a pop up stating:

"URGENT! Firefox no longer supports your operating system version and will be vulnerable to online attacks. <a>Learn More</a>"

And that doesn't sound like you guys. I'm using Mac OS 10.5. All my updates have been downloaded, the opening screen of this site tells me I'm up to date. Is this some kind of trick? I also have a screen shot of the occurrence, though not the url.

Please help. Thanks guys,

jen

Additional System Details

This happened

Just once or twice

This started when...

Not sure, most recent occurence was 10/28

Installed Plug-ins

  • Version 3.8.1.9672
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Shockwave Flash 10.3 r183
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • npmnqmp 071303000006
  • RealPlayer Plugin
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Hey Firefox,
Long time user, first time writer. Lately, apropos of nothing, I've been getting a pop up stating:
"URGENT!
Firefox no longer supports your operating system version and will be vulnerable to online attacks.
<a>Learn More</a>"
And that doesn't sound like you guys. I'm using Mac OS 10.5. All my updates have been downloaded, the opening screen of this site tells me I'm up to date. Is this some kind of trick? I also have a screen shot of the occurrence, though not the url.
Please help. Thanks guys,
jen

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8905 answers

hello jen, i think this is a genuine message, since firefox 16 was the last version which has been released for os x 10.5 and there won't be any future security upgrades for the browser.

Firefox no longer works with Mac OS X 10.5

James
  • Top 25 Contributor
  • Moderator
437 solutions 3163 answers

This will be the min requirements for Firefox 17.0 and newer.

https://www.mozilla.org/en-US/firefox/17.0beta/system-requirements/

Mac
Operating Systems
   Mac OS X 10.6
   Mac OS X 10.7
   Mac OS X 10.8
TreeRose 0 solutions 1 answers

Helpful Reply

Long time user and frustrated by this... is the solution to stop using Firefox? Because I certainly can't afford to go buy a new Mac just because I'm not eligible for newer operating system upgrades. My Mac isn't even that old... Suggestions?