Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Opening https://www.tumblr.com/ gives me the following error : Error code: ssl_error_rx_record_too_long on Mac.

  • 5 replies
  • 22 have this problem
  • 1062 views
  • Last reply by LeniA

more options

I get the following error:

An error occurred during a connection to www.tumblr.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

I am using Mac OS X 10.8.2 (OS X Mountain Lion)

None of the other browsers have any problems opening this website.

I am a novice user and I really love firefox, but can't use it since it won't open one of my favorite websites.

All Replies (5)

more options

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

You can use this button to go to the Firefox profile folder:

more options

Thank you for your prompt response.

However the above mentioned solution did not resolve my issue.

I am still facing the above problem.

more options

I removed cert8.db and secmod.db but my problem didn't solve.

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

You can also try to reset Firefox:

more options

I'm running windows vista and have the same issue. none of your solutions work!