X
Tap here to go to the mobile version of the site.

Support Forum

Google links fail to open unless https:// is at the begining.

Posted

For some reason, when I click on a link from google search or news, the link does not open unless I add https:// on my own. Once I do that, it opens right away.... Any ideas?

For some reason, when I click on a link from google search or news, the link does not open unless I add https:// on my own. Once I do that, it opens right away.... Any ideas?

Additional System Details

This happened

Every time Firefox opened

This started when...

Less than 2 months ago.

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • Citrix Receiver Plugin (Win32)
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Shockwave Flash 11.1 r102
  • BlackBerry WebSL Browser Plug-In
  • Java(TM) Platform SE binary
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12133 solutions 112705 answers

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

See also:

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/kb/Server+not+found *https://support.mozilla.org/kb/Firewalls See also: *http://kb.mozillazine.org/Error_loading_websites
alco 16 solutions 141 answers

Helpful Reply

* [[Enable SSL to fix the Firefox cannot connect securely error message]] * [http://kb.mozillazine.org/SSL_is_disabled SSL is disabled]
cor-el
  • Top 10 Contributor
  • Moderator
12133 solutions 112705 answers

Helpful Reply

Note that in this case it is the opposite: a secure connection works, but a normal connection doesn't work.

Quote: the link does not open unless I add https:// on my own

Note that in this case it is the opposite: ''a secure connection works, but a normal connection doesn't work''. Quote: ''the link does not open unless I add https:// on my own''
alco 16 solutions 141 answers

You are right about this!
Thanks for noting!

You are right about this! <br> Thanks for noting!