X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

In gmail the spell checker underlines the ends of words that are spelled correctly. Annoying at best.

Posted

running firefox 16.0.1 on pc with windows 7. This seems to have started with new version upgrade. In gmail the spell checker highlights last parts of words that are spelled correctly.

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Garmin Communicator Plug-In 4.0.3.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Picasa plugin
  • 5.1.10411.0
  • NPWLPG
  • npFFApi

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Is there a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

Question owner

Thanks for your post.

That does not seem to be the issue. I do have the English dictionary installed and spell check is checked. This was all working fine until the recent upgrade in Firefox to ver. 16. I have read that it is an issue with the new version and they are working on a fix, but have not come up with one yet... appreciate the assistance.

Best,

Jerry

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
it_is 0 solutions 14 answers

I have this problem too on Yahoo email and Yahoo forum comments and basically all over the internet that I'm typing with Mozilla Firefox. It's VERY annoying! Sometimes words that are spelled correctly are underlined too. PS: no useless questions! Sorry but let's cut thru the crap of useless replies that serve no other purpose but annoying the asker! We haven't selected or unselected or deleted anything! This is happening since the last few higher up versions of Mozilla firefox (like 14 or so). Thanks!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You probably see this bug (fixed in Firefox 21):

  • bug 812638 - (font_size_bloat) TB is inserting/adding loads of redundant/incorrect/random tags in the middle of corrected words (partially erased with backspace or DEL, then retyped) with certain valid font size attributes in HTML message source; causes spelling issues
  • bug 790475 - Spell checking broken (fixed in Firefox 19)

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)