X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

"This connection is untrusted" message on many (most?) sites (including some of Mozilla's) with V16.0.1.

Posted

"This connection is untrusted"

This message box pops up with most sites and links since I updated Firefox. This includes basic links in troubleshooting articles such as the SSL test and other "try this" links on the troubleshooting page. I have NOD antivirus and firewall enabled, and have no issues with other search engines (Explorer and Chrome). I like Mozilla and don't want to abandon it. Please help. Facebook was the first, but there are too many to list.

Chosen solution

Hi Deb98

if you have ESET go to setup > enter advanced setup > extend web and email tree > extend Protocol filtering > SSL > select Do not scan SSL protocol


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Read this answer in context 20

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • AppWorld NPAPI plugin
  • GEPlugin
  • BlackBerry WebSL Browser Plug-In
  • Unity Player 3.0.0f5
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

This statement scares me! how can I be sure?
You should only bypass the warning if you're confident in both the identity of the website and the integrity of your connection - even if you trust the site, someone could be tampering with your connection. Legitimate public sites will not ask you to add connection rule exceptions - an invalid certificate can be an indication of a web page that will defraud you or steal your identity.
I shouldn't have to bypass for every other site, should I???

ideato
  • Top 25 Contributor
617 solutions 4264 answers

Chosen Solution

Hi Deb98

if you have ESET go to setup > enter advanced setup > extend web and email tree > extend Protocol filtering > SSL > select Do not scan SSL protocol


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Question owner

From ESET: "ESET is aware of this issue and is working on a product update that will allow Mozilla Firefox to access websites that use SSL certificates with SSL scanning enabled. As a temporary solution, disable SSL protocol scanning to continue using Mozilla Firefox without interruption."

I had never had issues with ESET so I didn't think to check there first. The solution worked! Many thanks for your help.

ideato
  • Top 25 Contributor
617 solutions 4264 answers

you are welcome, i have nod32 antivirus for adout 3 years now and the newest version came up always with selected "Do not scan SSL protocol"  !!!

Modified by ideato

malcinblue 0 solutions 1 answers

Helpful Reply

I reset my date to resolve a printer issue earlier today. the messages started after this, I've now reset the date to the correct one and bingo - all is well again.

maybe a longshot for you but check it anyway.