X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Java 7 won't work with Firefox 16.0.1 on OS X 10.7.5.

Posted

Java 7 works with Safari, but Firefox won't recognise Java is there at all. I've tried reinstalling Java 7 but no success.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Office Live Update v1.0
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.4
  • 5.1.10411.0
  • View PDF documents within your web browser.
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • F5 Network Access plugin, Ver. 7000.2011.1102.1
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • RealPlayer Plugin
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello prw101

if you successfully install java ( http://java.com/en/download/help/mac_install.xml ) do the test to see if working ( http://java.com/en/download/testjava.jsp )

did you download java from java site or from : http://support.apple.com/downloads#java_for_os_x_lion ?

thank you

Question owner

Java 7 works with Safari, but not with Firefox. I downloaded it from the Java site-the Apple site only has a previous version of Java & it can't be downloaded.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

try to Re-initializing the plugins database and check it again

if the above does not solve the issue see if you can manually copy the contents of the java folder into Mozilla Firefox\plugins (i don't know the precisely position in mac)

thanks again

xwan510 0 solutions 1 answers

I have this problem too! Tried everything mentioned above. doesn't work. Can developer look into this issue?

komputist 0 solutions 1 answers

Helpful Reply

I reported this issue as a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=813803