X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Typing in URL bar causes Firefox to hang

Posted

Firefox has begun hanging whenever I type into the URL bar. Firefox will start normally, but this problem will invariably occur soon after it has finished loading. It appears that I am able to stop Firefox from hanging if I resize the browser window.

However, the only way that I have been able to work out how to prevent the problem is by using Firefox in Safe Mode. I have tried disabling various add-ons, resetting Firefox, reverting to a previous version, and even restoring my computer to an earlier restore point, and the problem persists.

Internet Explorer functions without any errors on the same computer. Is there anything I can do except hope that a new version of Firefox does not have the same problem?

Thanks,

Gregortz

Modified by Gregortz

Chosen solution

Try to disable hardware acceleration in Firefox.

Read this answer in context 2

Additional System Details

This happened

Every time Firefox opened

This started when...

Two days ago

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Win64; x64; Trident/5.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; Tablet PC 2.0)

More Information

Application Basics
Name
Firefox
Version
16.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adobe Acrobat - Create PDF
1.2
false
web2pdfextension@web2pdf.adobedotcom
Skype Click to Call
6.2.0.10687
false
{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20121010144125
browser.startup.homepage_override.mstone
16.0.1
extensions.lastAppVersion
16.0.1
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
Mobile Intel(R) HD Graphics
Vendor ID
0x8086
Device ID
0x0116
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Driver Version
8.840.7.1100
Driver Date
12-7-2011
Direct2D Enabled
Blocked for your graphics driver version.
DirectWrite Enabled
false (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Mobile Intel(R) HD Graphics) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
1/1 Direct3D 9
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

mm2012 1 solutions 19 answers

Helpful Reply

Extensions are a common cause of Firefox problems, including hangs, slowdowns, or periodic freezes. Check the list of problematic extensions to see if it is a known issue and go through the standard diagnostic steps related to extension issues to see if an extension is causing Firefox to hang.

http://kb.mozillazine.org/Firefox_hangs#Hang_loading_websites_when_using_an_automatic_proxy_configuration_file

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Chosen Solution

Try to disable hardware acceleration in Firefox.

Question owner

That seems to have solved the problem. Thanks cor-el!

Tommoco49 0 solutions 1 answers

I had a similar problem with Firefox hanging when using internet banking. The bank home page displayed ok, click on 'sign in' and second page displayed ok. Entered banking code, press 'submit' and Firefox hung. Did the same thing in IE9 and it worked ok. I tried the fix for this problem, 'disable hardware acceleration' and Firefox now works fine. (I am not a technical person, so no idea why this worked, just pleased I found the answer here)