Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Javascript isn't working, enabled, problem with websites

  • 4 replies
  • 10 have this problem
  • 4260 views
  • Last reply by roxcafe

more options

Hi, I was looking for help from two weeks now. Still can't solve this! :( My javascript is enabled, reinstalled java.com too. I deleted all my temp, history, cookies, removed add-ons, disabled kaspersky, checked it all in safe mode, installed firefox beta and all that..... now I'm just mad. The problem is javascript, I suppose, here are examples of sites that are not working for me: wireimage.com (trying to search or click on the thumbnail, where link is javascript:void(); - nothing happens) or viddy.com ie. http://www.viddy.com/video/b604f3a9-9b7d-4e60-bc7c-7bfe4ba89cf2?source=Featured where I should see play icon and video should load, but all I can see is black image. I have many sites like this. It's buggin me very much, that I'm very close to get chrome and delete firefox forever. Please help me! What I have to do to make it work again?

Chosen solution

Hey, thanks very much for your answer. I fixed this yesterday. Router settings changed everything. I don't have to use chrome anymore ;) I did back to stable version of firefox too. I think it was something to do with VPN pass and disabling it. Thanks anyway!

Read this answer in context 👍 0

All Replies (4)

more options

Is this problem new in the beta? Have you considered rolling back to Firefox 16.0.1?

In case some file is irreparably damaged, could you try creating a new Firefox profile? In addition to bypassing current add-ons and custom settings, it should have completely fresh settings databases and a fresh cache folder.

Close Firefox and from the Windows 7 start menu, in the search box type or paste:

firefox.exe /ProfileManager

Create a new profile accepting the default and giving it any name you like.

After starting up Firefox, test the problem sites. Any difference?

To switch between profiles, close Firefox and restart the profile manager.

To migrate data (selectively) see Recovering important data from an old profile. Alternately, you could use the Reset feature to auto-migrate key data to a new profile. See Refresh Firefox - reset add-ons and settings.

more options

Chosen Solution

Hey, thanks very much for your answer. I fixed this yesterday. Router settings changed everything. I don't have to use chrome anymore ;) I did back to stable version of firefox too. I think it was something to do with VPN pass and disabling it. Thanks anyway!

more options

Can YOu please post what actually solved it, so others can fix it too?

I think it had something to do with VPN

is not really helpful....

more options

I am sorry I didn't see your post before. Main thing I did was uncheck popup blocker in router settings. I really don't know much about this stuff, but for 99% that was it. I also changed these two: IPSec Passthrough: Enabled PPTP Passthrough: Enabled Router model is Cisco EPC3925.