X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Java Error message: evalInSandbox:SyntaxError: syntax error

Posted

Why is this error popping up all the time? How do I fix it?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Citrix Online App Detector Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Google Update
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • AppWorld NPAPI plugin
  • BlackBerry WebSL Browser Plug-In
  • RockMelt Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • GEPlugin
  • Office Live Update v1.5
  • NPWLPG
  • Version 0.9.4, copyright 1996-2008 The VideoLAN Teamhttp://www.videolan.org/
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Yahoo! activeX Plug-in Bridge
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

evalInSandbox:SyntaxError: syntax error
Application Basics
Name
Firefox
Version
17.0
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
DownloadHelper
4.9.10
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Google +1
1.1.0.9
true
{F9ABC0D1-06E6-4989-8211-B3246378C627}
Google Shortcuts
2.1.7.1
true
{5C46D283-ABDE-4dce-B83C-08881401921C}
ImTranslator
4.19
true
{9AA46F4F-4DC7-4c06-97AF-5035170634FE}
Integrated Gmail
2.8.7
true
{28197867-b1ef-4140-8e3b-55c45b9c8460}
Java Console
6.0.33
true
{CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA}
LastPass
2.0.0
true
support@lastpass.com
Lazarus: Form Recovery
2.3
true
lazarus@interclue.com
New Tab King
5.1.4
true
{FC5BAC7D-D696-4ba6-B913-CF8F000C33DF}
Pixlr Grabber
2.1.1
true
{d47a9f51-8281-43fa-f450-f28ef8735e9a}
printpdf
0.76
true
printpdf@pavlov.net
Quick Maps
1.9.0
true
map@quickmaps.me
Silvermel and Charamel XT
1.5.4
true
silvermelxt@pardal.de
Social Fixer
7.201
true
socialfixer@mattkruse.com
Stylish
1.3
true
{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}
Test Pilot
1.2.2
true
testpilot@labs.mozilla.com
WebMail Notifier
2.9.13
true
{37fa1426-b82d-11db-8314-0800200c9a66}
WiseStamp
3.11.21
true
wisestamp@wisestamp.com
Microsoft .NET Framework Assistant
0.0.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
624640
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20121010150351
browser.startup.homepage_override.mstone
17.0
extensions.lastAppVersion
17.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1350285519
places.history.expiration.transient_current_max_pages
26617
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) 82945G Express Chipset Family
Vendor ID
0x8086
Device ID
0x2772
Adapter RAM
Unknown
Adapter Drivers
igxprd32
Driver Version
6.14.10.4926
Driver Date
2-15-2008
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) 82945G Express Chipset Family) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
0
AzureCanvasBackend
cairo
AzureFallbackCanvasBackend
none
AzureContentBackend
none
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

Kadir Topal
  • Administrator
  • Moderator
22 solutions 175 answers

Hi pclind, this is probably related to extensions. You can try it out easily by starting Firefox in Safe Mode. Here is how: Troubleshoot Firefox issues using Safe Mode

It could also be the Java Plug-in. I'd just disable Java, if you don't really need it, most people don't. Here is how: How to turn off Java applets

Hope that helps.

daveposh 0 solutions 7 answers

I tried the two suggestions. Turning of java didn't make any difference. But running in safe mode with no plug-ins did work. These messages popping 4-6 times every time a page is loaded, started when I upgraded to beta 17.0 from the previous beta release.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

If it does work in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

See also:

daveposh 0 solutions 7 answers

Helpful Reply

I found the problem to be in the extension SocialFIxer 7.201. I have notified the author on his Facebook page https://www.facebook.com/Socialfixer Matt also has info on his website at http://socialfixer.com/

Thanks for the info on how to track it down!

suerreal 0 solutions 1 answers

No more pop-ups! Thanks for letting the Social Fixer people know.

vulcanmeister 0 solutions 1 answers

Thanks for the suggestion. I was using Social Fixer 6.751 and disabled it. Now Firefox 17.0 is happy again!

daveposh 0 solutions 7 answers

Helpful Reply

I was having the error Java Error message: evalInSandbox:SyntaxError: syntax error. Social Fixer has it corrected in version 7.301, and I am using Firefox 17.0 beta with Social Fixer 7.301 and not having any more of the errors.

illuminoidal 0 solutions 2 answers

I get the huge wave of Java messages since I upgraded to 17. Tried to revert to 16. That didn't work. I don't have SocialFixer Installed, or at least it's not in my add-ons list. And now I can't run except with all add-ons disabled.

Looks like it might be time to switch browsers again.

Modified by illuminoidal

illuminoidal 0 solutions 2 answers

wait, I take that back, I started up with all add-ons off, and the java messages still abound. Wow. Just wow.

windsorje 0 solutions 1 answers

I had this problem. It started happening this evening. By simply doing a System Restore the problem went away. Genius huh?

mauryh 0 solutions 1 answers

I don't have Social Fixer. How do you do a System Restore? This Java message drop down is sooooo annoying.