X
Tap here to go to the mobile version of the site.

Support Forum

Awesome Bar looks different in 16.01

Posted

Since upgrading from 15.0.1 to 16.01, i noticed the Awesome Bar looks larger and some things are highlighted. This is distracting to my eyes. Is there an add-on fix or rollback option?

Since upgrading from 15.0.1 to 16.01, i noticed the Awesome Bar looks larger and some things are highlighted. This is distracting to my eyes. Is there an add-on fix or rollback option?

Chosen solution

Try to add this code to the userChrome.css file below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

You need to create the chrome folder (lowercase) in the profile folder with the random name (xxxxxxxx.default) and place a file userChrome.css in it.
Make sure that you select "All files" and not "Text files" when you use Notepad or another editor to create and save the file.
Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.autocomplete-richlistitem { padding-top:2px!important; padding-bottom:2px !important; }
.autocomplete-richlistitem:not(:first-child) { border-top: 1px solid #ddd  !important; }
.autocomplete-richlistitem[selected="true"] { border-top-color:transparent !important; }

*|span.ac-emphasize-text {
 box-shadow: inset 0 0 1px 1px rgba(0,255,255,1)!important;
 background-color: rgba(0,255,255,0.2)!important;
}
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.3 r300
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Shockwave Flash 11.2 r202
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • ActiveTouch General Plugin Container Version 105
  • Yahoo Application State Plugin version 1.0.0.7
  • Unity Player 2.6.1f3
  • npdnupdater2
  • npdnu
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp
  • Office Plugin for Netscape Navigator
  • Rhapsody Player Engine Plugin
  • Allows browsing on RealArcade sites with Mozilla browsers.

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Question owner

It's still different in 16.02.

It's still different in 16.02.
cor-el
  • Top 10 Contributor
  • Moderator
17474 solutions 157940 answers

There shouldn't be any differences between Firefox 15 and 16

Can you attach a screenshot to illustrate what you want to change?

Use a compressed image type like PNG or JPG to save the screenshot.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
There shouldn't be any differences between Firefox 15 and 16 Can you attach a screenshot to illustrate what you want to change? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot. ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

I don't have Firefox 15 and can't get a screenshot because of that =\ But it appears slightly smaller than in 15, and highlights letters in the URL when i type them in, which hurts my eyes a bit.

I don't have Firefox 15 and can't get a screenshot because of that =\ But it appears slightly smaller than in 15, and highlights letters in the URL when i type them in, which hurts my eyes a bit.
cor-el
  • Top 10 Contributor
  • Moderator
17474 solutions 157940 answers

Are you referring to the auto-fill feature?

See "Prevent Firefox from automatically completing URLs":

You can set the browser.urlbar.formatting.enabled pref to false on the about:config page to disable the highlighting of the domain and see the full URL more clearly.

You can set the browser.urlbar.trimURLs pref to false on the about:config page to see the http: protocol on the location bar and in the pop-up if you hover a link.

Are you referring to the auto-fill feature? See "Prevent Firefox from automatically completing URLs": *https://support.mozilla.org/kb/search-your-bookmarks-history-and-tabs-awesome-bar You can set the <b>browser.urlbar.formatting.enabled</b> pref to <i>false</i> on the <b>about:config</b> page to disable the highlighting of the domain and see the full URL more clearly. You can set the <b>browser.urlbar.trimURLs</b> pref to <i>false</i> on the <b>about:config</b> page to see the http: protocol on the location bar and in the pop-up if you hover a link. *http://kb.mozillazine.org/about:config

Question owner

No, i mean how the Awesome Bar organized sites by the number of times I visited them.

No, i mean how the Awesome Bar organized sites by the number of times I visited them.
cor-el
  • Top 10 Contributor
  • Moderator
17474 solutions 157940 answers

Helpful Reply

Do any of these threads help or do you still mean something else?

Do any of these threads help or do you still mean something else? *[[/questions/939334]] How do i get the line between addresses back? *[[/questions/939644]] Firefox navigation bar no longer has lines in between suggestions/sites

Modified by cor-el

Question owner

That's it! I don't know any CCS though.

That's it! I don't know any CCS though.
cor-el
  • Top 10 Contributor
  • Moderator
17474 solutions 157940 answers

Chosen Solution

Try to add this code to the userChrome.css file below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

You need to create the chrome folder (lowercase) in the profile folder with the random name (xxxxxxxx.default) and place a file userChrome.css in it.
Make sure that you select "All files" and not "Text files" when you use Notepad or another editor to create and save the file.
Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.autocomplete-richlistitem { padding-top:2px!important; padding-bottom:2px !important; }
.autocomplete-richlistitem:not(:first-child) { border-top: 1px solid #ddd  !important; }
.autocomplete-richlistitem[selected="true"] { border-top-color:transparent !important; }

*|span.ac-emphasize-text {
 box-shadow: inset 0 0 1px 1px rgba(0,255,255,1)!important;
 background-color: rgba(0,255,255,0.2)!important;
}
Try to add this code to the userChrome.css file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder. *http://kb.mozillazine.org/Editing_configuration You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder You need to create the chrome folder (lowercase) in the profile folder with the random name (xxxxxxxx.default) and place a file userChrome.css in it.<br /> Make sure that you select "All files" and not "Text files" when you use Notepad or another editor to create and save the file.<br /> Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file. *http://kb.mozillazine.org/Editing_configuration/Troubleshooting ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ .autocomplete-richlistitem { padding-top:2px!important; padding-bottom:2px !important; } .autocomplete-richlistitem:not(:first-child) { border-top: 1px solid #ddd !important; } .autocomplete-richlistitem[selected="true"] { border-top-color:transparent !important; } *|span.ac-emphasize-text { box-shadow: inset 0 0 1px 1px rgba(0,255,255,1)!important; background-color: rgba(0,255,255,0.2)!important; } </nowiki></pre>

Question owner

Ok, let me see if that works!

Ok, let me see if that works!

Question owner

It worked! ^^ it highlighted some text in light blue which i didn't like but i figured out how to get rid of it =3

It worked! ^^ it highlighted some text in light blue which i didn't like but i figured out how to get rid of it =3
cor-el
  • Top 10 Contributor
  • Moderator
17474 solutions 157940 answers

You're welcome.

Yes, you can leave out that last bit or change it to this code if you want to disable the bold highlighting.

*|span.ac-emphasize-text {
 box-shadow: none !important;
}
You're welcome. Yes, you can leave out that last bit or change it to this code if you want to disable the bold highlighting. <pre><nowiki>*|span.ac-emphasize-text { box-shadow: none !important; }</nowiki></pre>

Modified by cor-el

Question owner

Is there a way to change it back to the bold highlight like in firefox 15? In 16 it's a light gray box.

Is there a way to change it back to the bold highlight like in firefox 15? In 16 it's a light gray box.