X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't watch Getting Started video on 16.0.1 install page with up to date Intel Mac 10.6.8 - no mp4 plugin?

Posted

"Getting Started" page for Firefox 16.0.1 has a video window that plays audio only. Firefox test page for plugins shows RealPlayer, Flash, Flip4Mac and Java are up to date. What other video plugins are required. I'm currently using Firefox 10.0.2 and I'm not inclined to update unless I have good reasons to do so.

Chosen solution

If it does work in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

See also:


Try to disable hardware acceleration in Firefox.

  • Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • DivX VOD Helper Plug-in
  • iPhoto6
  • Office Live Update v1.0
  • RealPlayer Plugin
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

jscher2000
  • Top 10 Contributor
2359 solutions 20906 answers

Do you mean this page: http://www.mozilla.org/en-US/firefox/central/

The small video should play natively in Firefox (HTML5 video), but if that isn't available, it falls back to the Flash player. If you click the video to start it, then call up the context menu for the player -- Mac equivalent of right-clicking the player area -- can you tell from the menu whether it is Firefox playing the video or whether Flash is involved?

If it's Firefox, there should be a menu item to Copy Video Location. Can you do that and paste the file name here to show what format is being played? I get a URL ending with "Browsing-Basics-640.webm".

Question owner

Thanks for your reponse. Yes, that is the page and Copy Link Location shows: http://www.mozilla.org/en-US/firefox/central/# Cheers

jscher2000
  • Top 10 Contributor
2359 solutions 20906 answers

Could you try Copy Video Location? You have to start the video before that shows up on the menu.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96729 answers

Firefox should play a WebM video natively if you open such a video link via the location bar.

Question owner

When the page opens I get a message that plugins are missing. Clicking on Install Missing Plugins comes up with Unknown Plugin (video/mp4); Manual Install takes me to the DivX Install page - DivX is up to date.

Once I start the video, Copy Video Location is not an option with Control-click. I can access Page Source, which seems to suggest that Flash is not installed although the Plug In check page says it is.

Is this extract from Page Source helpful?: div class="video-player-no-flash" This video requires a browser with support for open video or Flash.

There doesn't seem to be an option here to be able to attach the whole Page Source as a text file.

Cheers.

Modified by BigSash

Question owner

Same messages when I open via:

http://www.mozilla.org/en-US/firefox/video/

Modified by BigSash

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96729 answers

What happens if you open the WebM link that I posted above via the location bar?

Why don't you try updating to Firefox 16.0.1 to see if that works?

The Firefox version that you currently run is no longer supported with security updates.
It is important to update Firefox and add-ons to the latest versions to get the latest bug fixes and security updates.

Question owner

I replied above to your question re opening http://www.mozilla.org/en-US/firefox/video/ Same result.

I should have been receiving any important security updates if I don't want to upgrade - I do for the OS.

Upgrading in the past has meant a lot of work fixing up my Toolbars and menus and it generally takes more time than it's worth.

Question owner

I just started up in Safe mode and the video works!

Does this mean a clash of plugins? Which one(s) should I remove?

(Incidentally, I had previously tried with AdBlock off but that didn't solve the problem.)

Thanks for all your suggestions.

Cheers.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96729 answers

Chosen Solution

If it does work in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

See also:


Try to disable hardware acceleration in Firefox.

  • Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

Question owner

Disabling hardware acceleration didn't work, but I'll try disabling all extensions and then enabling one at a time.

Thanks for your help.

Cheers.

Question owner

Hi again

I disabled:

"DivX Plus Web Player HTML5

and video now plays.

Cheers.

Modified by BigSash