X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I have firefox 9.0.1 and "About Firefox" says Firefox is up to date. Is this true? Mac OS 10.7.3

Posted

I've seen much later versions of Firefox than 9.0.1 on other Mac computers lately. Yet whenever I check the "About Firefox" button, it gives the message that "Firefox is up to date". I have a MacPro, Intel Core i5 running OS 10.7.3, 4 GB memory, and 128GB SSD. I wish to find a "list" somewhere of Firefox versions vs. machine and OS's, and am unwilling to blindly download and install 15.0.1 without knowing if it's OK in advance.

Chosen solution

Yes, Firefox 15 will run perfectly fine on your computer. It is likely that the updater got messed up on your machine. Your best solution is to go to www.getfirefox.com, download Firefox 16.0.1, and install that over your current install.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • WebEx64 General Plugin Container Version 203
  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Chosen Solution

Yes, Firefox 15 will run perfectly fine on your computer. It is likely that the updater got messed up on your machine. Your best solution is to go to www.getfirefox.com, download Firefox 16.0.1, and install that over your current install.

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Helpful Reply

Hi jprusa,

Take a look at the system requirements for Firefox 16 which should be available in the next hour or so:

https://www.mozilla.org/en-US/firefox/16.0beta/system-requirements/

I don't think you should have any issues updating to that version. I would suggest you just try downloading a fresh copy from the downloads page. As I mentioned, 16.0.1 will be available later today. I'd wait for that version to be available!

John99
  • Top 25 Contributor
  • Moderator
624 solutions 8068 answers

Firefox 15 is or was the latest ordinary release of Firefox. Firefox 16 is in the process of being Released, but has had a couple of hiccups resulting in 16.01 and 16.02 being prepared as replacements.

Firefox normally now aims to release a new version about every 6 weeks. OS 10.5.03 is only supported up to Fx 16.

If you are on Firefox 9 it is outdated, unsupported and not secure, so you should update. There is a remote possibility you are on a more up-to-date version than is showing aside.

Modified by John99

Question owner

Thanks to each of you. I just downloaded and installed 16.0.1 and everything seems to be working fine. Curious that updater just stopped working though... All the best, J. Prusa