X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Corporate environment, no rights to update software, Plug-in check is a pain - how to prevent it?

Posted

The Plug-in check page has been appearing every time I start Firefox for the last couple of weeks. I'm in a corporate environment and have no rights to download any software. Yes, our versions of software are old. No, I can't do anything about it. Just get out of my face, please... Too much to ask?

- And by the way, I don't like the hoops you make me jump through before I can ask this question, or the unhelpful replies that are all that is offered for the question about the Plug-in Check screen.

Chosen solution

I've loaded my homepage URL into plugins.update.url - now I just have two tabs with the home page.

Read this answer in context 2

Additional System Details

This happened

Every time Firefox opened

This started when...

2 weeks ago

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • Default Plug-in
  • Shockwave Flash 11.0 r1
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • iPrint Plug-in 1.0.0 - Provides iPrint client services for Windows
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Classic Java Plug-in 10.7.2 for Netscape and Mozilla
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Your best option is to contact your corporate IT, they should update the software you are using (including Firefox) as that is leaving not just your computer, but the whole company network as well.

Helpful Reply

Our corporate IT are very conservative. They may well take years to update versions of software. In the meantime, everyone who uses Firefox has to delete this tab every time they start the browser. What's the point of that? And why did the plug-in check just recently start happening, I wonder?

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Helpful Reply

The reason the information appeared is we recently rolled out an update to notify users that they are running insecure plugins (you are in the minority of users who can't update). To disable this, you can set these prefs to true on the about:config page.

  • plugins.hide_infobar_for_missing_plugin
  • plugins.hide_infobar_for_outdated_plugin

Please note again the risks, and if need be pass this thread onto your IT department (or put them in touch with me) as they shouldn't be running this ancient of software on their network.

Question owner

Thanks for the instructions. Where would I find the about:config page?

I assumed it was under Help\About, but I can't see anything there.

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

type about:config into your address bar, press Enter

Question owner

OK, done as per your instructions. And rebooted. The plugin check still appears.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97054 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

"At the top of the Firefox windowOn the menu bar, click the Help menuFirefox button, go over to the Help menu and select Restart with Add-ons Disabled.... Firefox will start up with the Firefox Safe Mode dialog. For Windows XP, click the Help menu and select Restart with Add-ons Disabled.... Firefox will start up with the Firefox Safe Mode dialog. Note: You can also start Firefox in Safe Mode by holding down the shift key while starting Firefox."

No Firefox button, no "Restart with Addons disabled" under Help, and starting Firefox with the Shift key down has no effect.

At any rate, I know Firefox and add-ons are out of date. What I am asking is, GIVEN that I can do nothing about this situation, HOW do I get rid of the plug-in check? Of course it would be less effort to close that tab three times a day for 3 years than to engage in this dialogue...

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97054 answers

Those menu entries and methods do not apply to Firefox 3.6.x
In Firefox 3.6.x you can only start in Safe mode via the -safe-mode command line switch.

You may have a hotfix extension installed that open the plugin check page.

Question owner

Okay, I opened Firefox in safe mode, and it showed me theplugin check. It has been clear all along why it's showing this. I can't do anything about the out-of-date plug-ins. How do I stop the plugin-check appearing?

Yes, I know, close the tab every time I go into Firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97054 answers

Try to modify these prefs on the about:config page:

  • plugins.update.notifyUser -> false
  • plugins.update.url -> empty String

Question owner

plugins.update.notifyUser -> false -- was false already

plugins.update.url -> empty String - Done. Now when I start Firefox, I get a blank tab instead of one with the plugin-check details on it.

How do I stop it bringing up the blank tab?

Chosen Solution

I've loaded my homepage URL into plugins.update.url - now I just have two tabs with the home page.