X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Google.com (and google search through search bar) does not work on Firefox (but does work on Safari)

Posted

All of a sudden today, Google.com no longer loads through Firefox. Although it does load through Safari. I also cannot load a search through the search bar. (GMAIL still works).

Chosen solution

Neither of these were the answer. Frustrated with using Safari, I just deleted Firefox and reinstalled it. This solved the problem.

Read this answer in context 1

Additional System Details

Sites Affected

http://www.google.com

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/536.25 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.7

More Information

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8043 answers

Lets hope it was an intermittent problem and is working again. At the moment I am able to use various Google search sites & methods I am not personally seeing a problem.

If necessary try clearing the cache and cookies for Google related sites and trying again. There may have been a few similar posts but I would expect a veritable deluge if everyone is seeing such problems.

(IIRC the last major google problem related to how one of their animations was handled in Firefox )

Please post back with whether you still have a problem.

And anyone else with the same problem please vote on the thread, ussing the box at the side to register the fact.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hi tallgaloot

also delete the search.sqlite and the search.json in the Firefox Profile Folder and check if you can search with your search bar.

see for more info : Unable to search or add new engines


thank you

Chosen Solution

Neither of these were the answer. Frustrated with using Safari, I just deleted Firefox and reinstalled it. This solved the problem.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8043 answers

Glad it is working again.

One wonders whether switching between and uninstalling and reinstalling browsers may have cleared caches & or cookies, or alternatively that it was genuinely an intermittent problem.

I am glad it worked but a pity you resorted to uninstalling and re-installing Firefox.

GrumpySteve 0 solutions 9 answers

Helpful Reply

I too have this problem or a similar one. I can go to google.com (or .co.uk) and type something in to the search box, apparently normally - it switches to the search box at the top, and the auto-suggestion works, but when I hit return, that's it. Nothing happens. A big expanse of sodall below the search box. Click to maps and it works as expected, even carrying the search over. News ditto. When you get the second line of commands on the google screen, "web" does work - but "search" (in the back top bar) doesn't. And as soon as you change the search, it goes back to the page that doesn't work. Disable javascript and it works properly. I delete all cookies, cache etc automatically when I exit firefox (or I did in the older versions - I guess it's still operational). So - google or firefox?

Modified by GrumpySteve

GrumpySteve 0 solutions 9 answers

Just found another similar thread, so we are dividing our efforts! Win XP, doesn't work in safe mode. Refresh causes it to work. Reinstalled latest version - didn't fix it!

mfratto 0 solutions 3 answers

Seeing the same issue today, Firefox 17.0.1 on Windows 7 64 bit. What is happening is the first time I search, I get results, but I can't get to any other result pages nor can I search. I get the personlization bar, search form, and white screen. I disabled all add-ons, started in safemode, cleared everything and it still fails.

Oddly, if you go to google.com and hit 'Advanced Search', search will work until you make your next query.

The resulting URL is very different when searching from the search bar and searching from the page.

Modified by mfratto

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Helpful Reply

some users have reported that the issue might have been caused when the dom.storage.enabled preference in about:config was set to false. [source]

other users have reported that the search problem only appeared when they had firefox set to block cookies from google.com or one of its local domains. can you check if this is the case for you when you go into firefox/tools > options > privacy > accept cookies - exceptions...

another possible solution might be to disable javascript on google to make the search work again. alternatively you might use the firefox search bar to do a google search or use https://www.google.com/webhp?complete=0 until this is somehow addressed by google...

mfratto 0 solutions 3 answers

I followed the link on how to check dom.storage.enabled and toggled it to 'true' and for now, Google search is working from the page. Now the question is, how did it get toggled to 'false'. I did not toggle it so I suspect an add-on did.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

it might have been anaddon or tool related to privacy, since DOM storage is sometimes also referred to as "super cookies"

http://en.wikipedia.org/wiki/Web_storage

mfratto 0 solutions 3 answers

Good tip.

Firefox just updated today to 17.0.1 and while it checked for add-on compatibility, it didn't update any (at least not that I am aware of).