X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Whenever I start Firefox I get two windows, One is my regular home page, the other is a Mozilla plug-in check.

Posted

Everytime I open Firefox I get two tabs starting. One is my regular homepage and the other is https://www.mozilla.org/en-US/plugincheck/. I fixed the one plug in I wanted to fix but now I can't get rid of the plugincheck tab. The "Automatically check for updates" is disabled in the Tools-options-advanced-updates section of FFox but the extra tab persists.

Chosen solution

FIXED!!! Despite your good suggestion, I hated to throw out the baby with the bath water, knowing that the PROBLEM must be something tiny within the works, although difficult to find, I think I've fixed this problem. It's been two days and there has been no reoccurence of duo tabs. I'll begin with my train of thought followed by the solution.

Because the problem only began early this month I thought I'd look at every file inside the C/ Program Files / Mozilla Firefox folder looking MANUALLY for any files that were Modified recently. I saw a file called : nppdf32.dll (102kb) that was modified 3 Oct 2012 so deleted it to see what happens. (moved to desktop folder) Sure enough, after rebooting, it was re-created automatically by the same name (85kb) and everything works normally without Firefox dashing off to Mozilla's 'check plugin' page.

Stability and contentment have been achieved, Stav

Read this answer in context 5

Additional System Details

This happened

Every time Firefox opened

This started when...

I had been using FF during the day and it started one time when I started ff and will not "go away"

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.1"
  • Default Plug-in
  • Shockwave Flash 10.3 r183
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • Classic Java Plug-in 10.7.2 for Netscape and Mozilla
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28

More Information

changed my home page but any home page I used resulted in the same problem.

Michalis 18 solutions 193 answers

If you update your firefox to the lastest version maybe it will fix your problem https://www.mozilla.org/en-US/firefox/new/

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

See these articles for some suggestions:

If you do not keep changes after a restart then see:

See also:

Question owner

Hi,

thanks for your reply. I have changed the home page a couple of times and there aren't multiple home pages listed. It appears that all my preferences are properly saved. I still get two tabs opening when I start FF.

Al kruhm

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Did you try to check for problems with preferences?

Try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

You can also try to delete the addons.sqlite file and the pluginreg.dat.

You can use this button to go to the Firefox profile folder:

Question owner

Hi, I did try running FF in the safe mode and disabling add-ons and restoring default preferences but this didn't help. What I did do was to Uninstall FF 3.6.28 which I was using, including all the prefs, bookmarks, etc., and to re-install an old version 2.0.0.20. I re-installed my bookmarks and reset my pref's and it's been OK the last 5 or so times I've started it. Only time will tell <G>.

One of the things that confuses me is how I got into this predicament in the first place.

Thanks, Al kruhm

Question owner

Hi, Thanks for your response.

I was able to fix my problem bu uninstalling FF 3.6, including preferences, etc., and reinstalling an earlier version, 2.0.0.20, which works for me. What I don't know is how I got the problem in the first place.

Regards

Al

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You should not go back any further (2.0.0.20 is really really too old and won't work on a lot of websites) and either stay with 3.6.28 or better update tomorrow to Firefox 16.

If you can't fix your current profile then create a new profile.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

Question owner

Thank you. I'll try 3.6 again.

Stav 1 solutions 5 answers

I too have this problem where when you first launch FireFox (mine is the lovely & solid V3.6.11) you get two tabs loading at the same time with the forground one (2nd one) being the Mozilla PluginChecker page: It was useful to see it the first time but having made its point is getting scary with its relentlessness.

Is this Mozilla's intention or malware or a bug? Upgrading to the latest FireFox is NOT an option for me, and by the sound of some of the folks in the forum can be regrettable. I tried upgrading once and it broke too many profile elements, so have been happily loving the less intrusive and more stable 3.6.11.

Your biggest fan, Stav

One additional detail for those fixing this: My homepage is intentionally BLANK. When I open Firefox it's fine and sits there quietly. The double tab dilemma occurs once you ask it to go to any site or if you click on a link to launch FF. Once you close that tab its fine until you quit.

Stav 1 solutions 5 answers

I lied ... the moment you launch Firefox it tries to connect to https://www.mozilla.org/en-US/plugincheck/ . I wrote it waited until you selected a destinatin but not so. It's strange that it only started doing this a few days ago the same time our friend at the top 'aokruhm'.

Replacing Firefox is NOT the solution, unless you like throwing out the baby with the bath water, because FireFox V3 was happy last week.

MY BIG QUESTION is : What changed? Anyone?! Has FireFox infected all of us with older versions to force an upgrade? That's what it FEELS like.

Question owner

Hi,

Yes this was exactly my problem with 3.6.28.

The only was I was able to fix it was to uninstall FF 3.6 and all the profile info and reinstall ff 2.0.0.20 which mostly works for me. I might try to upgrade to 3.6 and try again but, as they say, if it ain't broke-don't fix it.

Regards Al

Stav 1 solutions 5 answers

This may sound too simple, but after searching the net I came across this solution that 'seems' to work! Read it carefully and follow it to the letter, (even though it may seem to repeat itself).

BEST Answer -

1. Go to Firefox preferences and change the homepage to blank.

2. close all tabs except the blank one.

3. now quit and restart firefox

4. close all other tabs but the blank one

5. quit firefox and restart.

6. now surf to your homepage you want

7. hit preferences and set current page as your homepage

8, quit firefox and restart.

    all should be normal.
   thanks for the help eggman

So far so good AND I get to stick with Version 3.6.11 Hurray, Stav

Stav 1 solutions 5 answers

Sorry. I spoke too soon. That didn't fix it. dang, Stav Help!

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8037 answers

It is probably best if you start your own thread about your own question

You may find solutions can not be found if you use an unsupported old version of Firefox that is not secure.

Stav 1 solutions 5 answers

Chosen Solution

FIXED!!! Despite your good suggestion, I hated to throw out the baby with the bath water, knowing that the PROBLEM must be something tiny within the works, although difficult to find, I think I've fixed this problem. It's been two days and there has been no reoccurence of duo tabs. I'll begin with my train of thought followed by the solution.

Because the problem only began early this month I thought I'd look at every file inside the C/ Program Files / Mozilla Firefox folder looking MANUALLY for any files that were Modified recently. I saw a file called : nppdf32.dll (102kb) that was modified 3 Oct 2012 so deleted it to see what happens. (moved to desktop folder) Sure enough, after rebooting, it was re-created automatically by the same name (85kb) and everything works normally without Firefox dashing off to Mozilla's 'check plugin' page.

Stability and contentment have been achieved, Stav

wabi 0 solutions 1 answers

Same problem. NOW SOLVED.

What fixed it for me was looking at my Firefox > Addons list within the browser itself. There was a message saying there's a problem with my Foxit Reader Addon. I Disabled this Addon and the annoying Addon Check Tab went away.

So in reality Firefox was doing it's job to warn me about one of my Addons, it just wasn't very helpful in letting me know which one until I dug into the settings.

Hope that helps someone else.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8037 answers

I saw a file called : nppdf32.dll (102kb) that was modified 3 Oct 2012 so deleted it to see what happens.

That will be a File used by the Acrobat pdf reader I believe. The reader is a standalone AND may be used as a Firefox plugin. Although there are other methods of reading pdf s. It is probably a good idea to keep acrobat up to date and you may check by using