X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

downloaded new version of Java but doubled clicked on it and it will not install, message says i need to open it with an application and wants me to choose one.

Posted

firefox disabled my version of java, i went to the free download site to get the newest version, clicked on download then doubled click on it in the download list, this should have started the intallation but instead i got a message saying i needed an application to open the link and wanted me to choose an app. Install box did not come up as it has with other downloads. I do not want to open it i want to install it.

Additional System Details

Installed Plug-ins

  • 6.0.12.1662
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • Default Plug-in
  • Shockwave Flash 10.0 r12
  • 4.1.10329.0
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

Michalis 18 solutions 193 answers

Helpful Reply

Where did you download the java?

Download it from here https://www.java.com/en/download/index.jsp