X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable the plugin check at Firefox startup?

Posted

Starting in the last day or two, every time I start Firefox, in addition to my homepage, I get a nuisance tab that is checking my plugins. I need to disable this stupid function or I will have to discontinue using Mozilla Firefox after 20 years as a faithful Mozilla user. I am happy with, and have no intentions of upgrading, my version of Firefox (3.6.17). I also have no intentions of upgrading my Flash plugin as newer versions are incompatible with an online activity in which I engage.

I have followed instructions in the user forum for changing the status of plugins.update.notifyUser from true to false in "about:config", but it apparently resets itself to true. None of the user forum suggestions correct this problem. If this unwanted, stupid tab cannot be disabled, I guess I will have to abandon Mozilla, both for Firefox and Thunderbird, and pursue options that do not force unwanted content on the user.

In addition, it seems impossible to actually speak to anyone at Mozilla about the problem. So hopefully someone will answer this question with a solution to the problem.

Additional System Details

This happened

Every time Firefox opened

This started when...

In the last day or two.

Installed Plug-ins

  • Garmin Communicator Plug-In 3.0.1.0
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Winamp Application Detector
  • Google Update
  • Shockwave Flash 11.0 r1
  • GEPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • 5.1.10411.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Classic Java Plug-in 10.7.2 for Netscape and Mozilla
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 ( .NET CLR 3.5.30729)

More Information

Application Basics
Name
Firefox
Version
3.6.17
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Garmin Communicator
3.0.1
true
{195A3098-0BD5-4e90-AE22-BA1C540AFD1E}
Microsoft .NET Framework Assistant
1.2.1
true
{20a82645-c095-46ed-80e3-08825760534b}
Kaspersky Virtual Keyboard
12.0.0.477
true
virtualKeyboard@kaspersky.ru
Kaspersky URL Advisor
12.0.0.477
true
linkfilter@kaspersky.ru
Adblock Plus
2.0.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
30
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
file:///C:/Stuff/Start.html
browser.startup.homepage_override.mstone
rv:1.9.2.17
browser.tabs.loadInBackground
false
dom.disable_window_move_resize
true
dom.disable_window_status_change
false
extensions.lastAppVersion
3.6.17
font.name.serif.x-western
Arial
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729)
network.cookie.lifetimePolicy
2
network.cookie.prefsMigrated
true
places.last_vacuum
1345339645
print.print_printer
Microsoft XPS Document Writer
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_pagedelay
500
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11.00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8.50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1.00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.cpd.sessions
false
privacy.cpd.siteSettings
true
privacy.popups.firstTime
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false

skyyye 0 solutions 1 answers

I've spent almost the last 3 hours trying to solve this (I'm using version 3.6.28). Changing the about:config setting didn't stick, starting in safe mode didn't help, etc.

Finally I did the following: 1) Used MozBackup to save all my settings, bookmarks, history, etc. 2) Uninstalled Firefox 3) Deleted the C:\Program Files\Mozilla Firefox folder (although I saved the searchplugins folder first) 4) Reinstalled Firefox version 3.6.28 5) Used MozBackup to restore things 6) Verified everything was restored (I had to reinstall 3 extensions, and re-disable the plugins that I keep off, and copy those searchplugins into the new folder, but MozBackup pretty well got everything back the way it was)

Now I am no longer getting the plugin check. It seemed that something was just goofed up with Firefox itself, so maybe a reinstall would get rid of whatever problem had come up, and yeah, it looks like that worked.

98firefox 0 solutions 1 answers

Helpful Reply

I'm using 3.6.24, and I got that same Plugin Check tab (after using it for a looooong time) after I decided to re-enable ConvertHelper for DownloadHelper.

It let me know that it had disabled my outdated Java. It also complained that my Shockwave Flash was "vulnerable", VLC Multimedia Plugin was "unknown", and Adobe Acrobat was "outdated".

Like many, I can't update the plugins, because I'm already using the latest versions supported by my system.

I don't know what hidden settings got changed, and I tried all the usual suggestions here and on the InterWeb, until I finally got to:

http://kb.mozillazine.org/Plugin_scanning

As suggested there, I went into about:config and changed: plugin.scan.plid.all from "true" to "false"

Closed and restarted; it still complained about Java and Acrobat.

Went into about:config again, changed: plugin.scan.Acrobat from "5.0" to "9"

Closed and restarted.... ONLY MY HOME PAGE! YAAAAY!!!!!

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Note that you have both the Classic and Next Generation Java plugin (you only need the latter and not the Classic plugin).

  1. Classic Java Plug-in 10.7.2 for Netscape and Mozilla
  2. Next Generation Java Plug-in 10.7.2 for Mozilla browsers
PaulaAllen 0 solutions 1 answers

I have had this problem too. I tried both methods posted by other users and was unsuccessful. It is so annoying that I will no longer be using Firefox. Goodbye.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can get a plugin check on startup if you have plugins that are blocklisted by Mozilla,either because of security vulnerabilities or by causing excessive crashes and thus are disabled.

JavaJive 0 solutions 2 answers

I've got rid of this problem by going into ... about:config ... and setting the following to false (note: this is a DIFFERENT setting to that mentioned above): extensions.blocklist.enabled

It's probably not a great idea in terms of security, but it works.

JavaJive 0 solutions 2 answers

Further to the above, depending on which plugin(s) is/are causing the problem, you may need either or both the settings in about:config set to false. That is: extensions.blocklist.enabled & plugin.scan.plid.all

Modified by JavaJive

cadaver1971 0 solutions 1 answers

delete/get rid of this file---> nppdf32.dll in c/program files/mozilla firefox/plugins ..

restart and the second tab is gone

hope this helps i have Win 7

ozzirt 0 solutions 2 answers

I did as you said and removed <nppdf32.dll>

It worked,... Thank you

Modified by ozzirt

ozzirt 0 solutions 2 answers

Helpful Reply

This is a pain in the arse. There is only one thing worse than security problems, and that is being spammed by software developers who want to tell you what Plugins you want to run.

Sorry, you got it all wrong if I want to stay with a version, that is MY choice.

Modified by ozzirt

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

You know by staying on an old version of Firefox and old plugins you are leaving yourself open to these security problems right? Staying with an old version and knowingly leaving yourself vulnerable is pretty ridiculous.

Nap_BlownApart 0 solutions 1 answers

Latest isn't always greatest! Besides, as time goes by, developers make ever more assumptions on our behalf of what they think we want, and they often get it wrong.

I stated using Firefox a very long time ago because I wanted more privacy. Security, privacy, etc in IE is based on Microsoft's view. This didn't align with what I thought on the same issues, hence I changed.

This plugin check is something I should be able to initiate of my own accord, rather than keep Mozilla (or anyone else) up to date on what plugins I'm using.

I too want to turn this 'feature' off! But no one is able to explain how, other than hacking into the about:config page... NOT HAPPY.

@Tylerdowner: Can you elaborate on what the security risks are? On what basis are you making this claim?

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

You can initiate the plugin check on your own (go to https://www.mozilla.org/plugincheck/) but for those users who don't have up to date versions of the plugins, we encourage them to update. We aren't telling you to install new ones, just informing you that the versions you have are out of date and insecure.

If you want information on the security vulnerabilities, sure.

https://www.mozilla.org/security/known-vulnerabilities/firefox.html If you are using Firefox 3.6, you are vulnerable to pretty much every hole here from Firefox 11 to Firefox 18.

http://www.adobe.com/support/security/ For the Various Adobe related security bulletins. (I don't know what plugins you are running, so I can't give you specifics on what will affect you).

It's well known that not updating your OS, Browser, Plugins, etc. will leave you open to stability, performance and security holes, so it should always be your top priority. Nobody is trying to be "big brother", we just know that you can't always keep up with the latest versions, so we are trying to help keep you up to date and save you the pain of a security breach. We are all on the same team, which is trying to make the web better for you and everyone on it :)

wobble201 0 solutions 1 answers

Utter rubbish, all green OK's yet still get the nag tab. Not nice being called ridiculous either! After many years bye bye.....

RumourControl 0 solutions 4 answers

Tyler,

You need to bother to seriously read what people are saying and not come out with that utter jargon above. Calling people’s choice to update ridiculous is also not a bright move considering the amount of people expressing the same problems. I’ve only registered same as the others to express my bafflement at this reaction to this problem.

The average user doesn’t really care (well I certainly don’t) one way or the other about what plugins are updated in what manner for security so long as it is done pain free. What they do care about is being spammed every time they open their browser with an update page – even though they have fully updated and all have recognised safe plugins like myself! Now that is ridiculous. That needs someone to fix it now.

So basically, you are telling us because some people are too stupid to update themselves and risk problems you’re forcing an update check on us all every time we open the browser? Because that’s sure what it sounds like! Some of us are actually competent in our security, but apparently you didn’t consider that.

I like probably many others with this problem are running version 18 and up-to-date plugins – so the problem is your guys end – it is still happening. This is why I never actually update FireFox (did I mention that part?) because until it upgraded on my behalf to 18 I had no problems.

Fix it or except your users levels to drop – because nobody likes sloppy work that we have to try and work out how to fix because you won’t do it.

Yes, I am sure this like all these things before it will be fixed in time and not soon enough; but you’ll do well to remember it’s this kind of software behaviour everyone using FireFox is the very thing we are trying to get away from! I like many dropped the others browser’s for the constant niggles such as this.

Come-on guys just sort it out with a practical solution will you please?

-RumourControl

kryssy 0 solutions 1 answers

Hi, I am a complete numpty with my PC most of the time but was suffering this "update" problem for a while before landing here.

I don't know if this helps but I changed the extensions.blocklist.enabled in about:config to false (as suggested by JAVAJIVE) and then panicked a bit and after closing and reopening my browser a couple of times without the tab popping up, re-set it back to true and I still don't get the warning tab opening. This may be a fluke but maybe not.

Just thought it would help. Also agree with the comments made by RUMOURCONTROL. Well done.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

Rumor Control, if you are running Firefox 18 with up to date plugins, then you are having a different problem than this thread is about. This is for Firefox 3.6 users who have old plugins, not those with updated software.