X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox only opens https:// version of any site!

Posted

No matter what I do, Firefox will only open the https:// version of ANY site. When I look at my extensions and plugins, I don't see anything that would be causing this, but it's very frustrating. Any ideas?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Version 3.8.1.9672
  • Google Talk Plugin Video Accelerator version:0.1.44.21
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Adobe Acrobat and Reader Plug-in for Web Browsers, Version 7.0.0
  • 5.1.10411.0
  • Facebook Video Calling by Skype
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • RealPlayer Plugin

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

You can set the Boolean pref browser.urlbar.autoFill to false on the about:config page to disable auto-complete.

See "Prevent Firefox from automatically completing URLs":

You can set the browser.urlbar.trimURLs pref to false on the about:config page to see the http: protocol on the location bar and in the pop-up at the bottom if you hover a link.