X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

soft scrolling does not work as expected

Posted

With "soft scrolling" I expected that, when pressing the UP or DOWN arrow keys, the entiere page will move "softly" and rather slowly. But this does not seem to work. Instead, pressing one of these keys makes the curser rush through the frames line-wise, "jumping" speedily over "gaps" - - - which is of little use. Is there a way I could achieve that "soft scrolling"? My OS is Windows XP 32 Professional.

Chosen solution

Unselecting "Caret Browsing" solved the problem! Thanks anyway!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

ideato
  • Top 25 Contributor
616 solutions 4260 answers

Helpful Reply

Hi Panurg

go to about:config find

general.smoothScroll.lines.durationMinMS right-click on it, select modify and change the value to 1500 , click OK to save it

do the same with general.smoothScroll.lines.durationMaxMS and check it again.

check the scrolling with your up and down arrows and select a value, i think something between 1500 and 2000 is ok for you.


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Question owner

This did solve the issue - partly...

In fact, the scrolling still isn't a proper scrolling, but is somewhat jerky, uneven, - - - but slower so. I would appreciate an evenly-speeded motion, as it comes when permanently held the arrow-field at the vertical scrollbar's ends.

Modified by Panurg

ideato
  • Top 25 Contributor
616 solutions 4260 answers

check also :

general.smoothScroll.mouseWheel.durationMaxMS general.smoothScroll.mouseWheel.durationMinMS

general.smoothScroll.other.durationMaxMS general.smoothScroll.other.durationMinMS

general.smoothScroll.pages.durationMaxMS general.smoothScroll.pages.durationMinMS

general.smoothScroll.pixels.durationMaxMS general.smoothScroll.pixels.durationMinMS

general.smoothScroll.scrollbars.durationMaxMS general.smoothScroll.scrollbars.durationMinMS

check one by one to find your preferences


thanks again

Question owner

Done ages ago ;-} Neither of these affect the "scroll" behaviour as described. I found out that I ask for a key shortcut for the small square arrow fields on both ends of the (vertical) scroll bar. Only these, klicked-and-held, trigger what I call scrolling. The speed of this scrolling is indeed set by general.smoothScroll.scrollbars.durationMaxMS general.smoothScroll.scrollbars.durationMinMS

Question owner

Um... Have I unawarely said Jehova?? I assume the difference between scrolling and cursor shifting to be quite obvious. There are browsers where the UP/DOWN arrow keys are scroll-keys by default. In Firefox they are cursor shift keys. Is this a default that could be altered (e.g. to "scroll"), or is this a fix assignation? If the latter: Would it be possible to re-program this?

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96697 answers

See also this pref:

  • toolkit.scrollbox.verticalScrollDistance

Chosen Solution

Unselecting "Caret Browsing" solved the problem! Thanks anyway!

mos1975 0 solutions 1 answers

press f7 something to do with carat browsing just press it once