X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to Get Rid Of Singingtaco.com Adware

Posted

I'm running Firefox on a Mac.

Every google search comes up with the top result from singingtaco.com.

Somewhere/somehow I picked up spywhere/adwere.

Deleting Firefox and all the preferences got rid of it. Then adding back the preferences files to the library I had my bookmarks and plugins back.

This seemed to fix it for a few hours. But now the damn singingtaco.com is back.

How do I get rid of this thing for good?

Additional System Details

This happened

Every time Firefox opened

This started when...

Anytime I search google.

Installed Plug-ins

  • Version 3.7.1.9330
  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Shockwave Flash 11.3 r300
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • RealPlayer Plugin
  • Picasa plugin.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

alex_mayorga 12 solutions 164 answers

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try some of the following programs to scan for malware:

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96837 answers

The OP is on a Mac, so instructions for the windows platform won't help.

You can also try to clear the cookies.

Clear the cache and the cookies from sites that cause problems.

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Thanks.

I found the problem. It was one of the plugins. Not exactly sure which one though. I deactivated all of them except the ones I absolutely need and it went away.

SomtamSomchai 0 solutions 1 answers

I had the same problem and got rid of it by deactivating the FF extension "Fast Video Download (with Search Menu)" (FVD). You can also just change the setting for "Search Menu" in FVD.

Modified by SomtamSomchai