X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Does Roboform work on Nightly 18.0? My experience suggests no.

Posted

I installed nightly 18.0 yesterday and could not get roboform toolbar to appear. I uninstalled roboform and reinstalled while nightly was the default browser.

Chosen solution

Roboform doesn't support Nightly or Aurora, which are both "alpha" versions of what will eventually become a Firefox release version. I'm not sure if they even support Firefox Beta versions. You would have to check with Siber Systems support to see if they have regular user's doing Beta testing of Roboform in Firefox Beta,

Their program, they decide what they support.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Shockwave Flash 11.2 r202
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • Picasa plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3196 solutions 24401 answers

Chosen Solution

Roboform doesn't support Nightly or Aurora, which are both "alpha" versions of what will eventually become a Firefox release version. I'm not sure if they even support Firefox Beta versions. You would have to check with Siber Systems support to see if they have regular user's doing Beta testing of Roboform in Firefox Beta,

Their program, they decide what they support.

pfbird 0 solutions 1 answers

Thank you, rpiner, for raising this question. Thank you, edmeister, for answering it. You saved me a lot of time beating my head against the wall trying to fit a square peg in a round hole. I hope Siber Systems comes through eventually.

the-edmeister
  • Top 10 Contributor
  • Moderator
3196 solutions 24401 answers

It's a lot more work to support the the alpha versions, which may have code changes daily, than it is to support Release versions only. Few 3rd party add-ons support alpha versions of anything.

SNUSA 0 solutions 1 answers

Working fine for me on FF18 beta4... (PortableApps edition) (Roboform Lite v.3.1.0 anyways)

How I did it: (With Roboform Lite v.3.1.0 working in Portable FF 17x.)

  1. Used FEBE to backup all extensions from FF17 portable.
  2. Installed FEBE into FF18.
  3. Restored everything to FF18 in new "Profile."
  4. Added ProfileSwitcher to FF18.
  5. Now load FF18beta4 & use ProfileSwitcher after loading FF17.

(profiles are not supported yet either via the command line apprently, but ProfileSwitcher takes care of this)

Now FF18 beta4 has all my add-ins.... (more "fluid" & smoother than FF17) (PortableApps version even updated automatically from beta3 to beta4)  :-)

Modified by SNUSA