X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Additional System Details

Sites Affected

http://google.com

Installed Plug-ins

  • 4.1.10329.0
  • Heppkat Communicator
  • iTunes Detector Plug-in
  • Shockwave Flash 10.3 r181
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPWLPG
  • CANON iMAGE GATEWAY Mycamera Plugin
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Helpful Reply

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file.
Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates.
Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
sw4mpfox 0 solutions 1 answers

Helpful Reply

- Make sure that the date and time on your PC are correct. - Sites have certificates for periods of time (01/03/2012 - 01/03/2013 for example). - If the date and time on your PC are not correct then your browser might think that the site you are trying to view has an expired certificate.

Just a guess!