X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Battlelog (for battlefield 3) does not work with Firefox 15.0.1. It works fine with the older Firefox 14.0.1

Posted

The flash features on the Battlefield 3 site - battlelog.battlefield.com do not work when Firefox updates itself to 15.0.1 It does not load the pages correctly or does it let you select/ click on anything in the flash parts. When I uninstalled 15.0.1 and reinstalled Firefox 14.0.1 I unchecked the option to let firefox re-upgrade itself and battlelog works fine.

Additional System Details

Sites Affected

http://battlelog.battlefield.com

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • 1.132.0
  • 0.70.4

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8019 answers

I do not wish you to break Firefox on Battelfield 3, but have you tried using the latest version of Flash Player. You should also remember that using outdated versions of Firefox increases security risks to your computer and personal data.

You may get an answer to this sort of question faster by asking on a forum related to that game site, (and if you do please post back with the solution preferably with a link).

Possibly you could consider using Firefox 15 and later as the day to day browser, and Firefox 14 only for the problem games.

  • The simplest way to do that may be to install Firefox portable (I assume that will run a Firefox 14 version)
  • A better way would be to install multiple versions of Firefox. That is often considered advanced, but I imagine most experienced computer users could do it easily (I can provide links to instructions). That has the advantage that the problem could be looked at a bit more closely, possibly even filing a bug if it appears to be a Firefox regression causing the problem.