X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't bypass security warning on previously accesable site

Posted

I have been accessing a Facebook app right along without any issues, and now suddenly Firefox is saying that the certificate is invalid and will not let me connect. The problem is that I am not being given the option to bypass the warning, all I get is the Get me out of here option. I have tried clering all histories, caches, etc. I have even gone so far as to uninstall Firefox, remove all personal settings, and reinstall it, and it still hasn't solved the problem. I have tried all the suggestions posted here, and they have not helped/

Additional System Details

Installed Plug-ins

  • Facebook Desktop Plugin
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • 5.1.10411.0
  • AmazonMP3DownloaderPlugin 1.0.15
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

DemocritusJr 0 solutions 1 answers

As jscher2000 pointed out the problem might be upstream.

In my case, the certificate was blocked by openDNS, which I chose to filter internet traffic. I had checked the proxy/anonymizer category, so when trying to access the Tor Project (https://www.torproject.org) both openDNS (and Firefox) did their job. The Technical Details helped me figure it out, though a bit elliptical:

www.torproject.org uses an invalid security certificate.

The certificate is only valid for the following names:

 *.opendns.com , opendns.com  

(Error code: ssl_error_bad_cert_domain)

Point is, it could be a lot of things, but Firefox most likely isn't it. And I'm not sorry it has high security standards!