X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Popup blocker is turned off in Firefox, but I still can't open popups on any site. Any ideas?

Posted

My system: Firefox 15.0.1 on Win 7 Pro 64bit with Norton AntiVirus 2012.

I have disabled Firefox popup blocker and I read up on Norton (it has not popup blocker) but still I can't open popups. Here is a perfectly safe site: http://www.thomann.de/de/allenheath_zed60_14.htm Click on the image and you should get a popup with a gallery containing more images of that product.

But in my Firefox it doesn't open that popup.

When I'm doing this with IE8 (I have that one too), it works perfectly.

Any ideas why the popups don't open in Firefox despite me having disabled the Firefox popup blocker?


Best, Alex

Chosen solution

Re-reading your response, I noticed "I also use NoScript but it is set to "Allow all except blacklist"". Where is that option in NoScript? How does it interface with a blacklist as NoScript does not have a built-in blacklist?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • ActiveTouch General Plugin Container Version 105
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • 5.0.61118.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

TheOldFox 110 solutions 619 answers

JavaScript (not Java) opens that window.

Do you have JavaScript enabled?

  • Options > Content > (x) Enable JavaScript


Other-

You need to update some other applications on your system that install plugins in Firefox. All of the following that are installed on your system have security issues that have been corrected in more current versions:
Shockwave Flash 11.2 r202
Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
Adobe PDF Plug-In For Firefox and Netscape "9.5.0"

Modified by TheOldFox

Question owner

Thanks for the hints. Here is my response:

  • JaveScript is enabled (always was)
  • I updated all plugins (see attached image)
  • The only plugins, I did not update are:
    • Microsoft Office 2010 (unknown plugin)
    • ActiveTouch General Plugin Container (unknown plugin)
    • QuickTime Plug-in 7.7 (Outdated Version but not vulnerable - I'm not a big QuickTime user, hence didn't want to update)

Result of above things: No change. Popups still don't open.

Note: I also use NoScript but it is set to "Allow all except blacklist" so JavaScript is not blocked because the pages I visit are all clear.

Can you suggest another path of action for my issue?


Best, Alex

Modified by Alex322

TheOldFox 110 solutions 619 answers

I also use NoScript, but temporarily allow sites as I feel that offers the best security. I use Request Policy add-on for finer-grained control of NoScript. I only had to temporarily allow thomann.de in NoScript for the pop-up window to appear. And I have "Block pop-up windows" checked with no exceptions listed.

My only other suggestion would be to try Firefox Safe Mode to see if an extension is interfering (maybe a firewall/anti-virus toolbar). If it works in Firefox Safe Mode you will need to restart Firefox to enable your extensions, then disable one or two at a time, restart Firefox, and repeat until you find the offender.

If all else fails, use Reset mentioned in the Safe Mode article. You will need to reinstall your extensions, a few at a time, then test, after the reset.

TheOldFox 110 solutions 619 answers

Chosen Solution

Re-reading your response, I noticed "I also use NoScript but it is set to "Allow all except blacklist"". Where is that option in NoScript? How does it interface with a blacklist as NoScript does not have a built-in blacklist?

Question owner

I simply deinstalled noScript. So noscript was the reason. I did not check which of noscript's numerous settings was the actual reason for the problem. I still like NoScript.

TheOldFox 110 solutions 619 answers

Must have been caused by some quirk in your NoScript settings as the site works fine for me with NoScript installed, after temporarily allowing the site in NoScript.

You can inquire on the NoScript forum - http://forums.informaction.com/viewforum.php?f=3 (registration is required)