X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Download Problems

Posted

I am using Ubuntu 4.0.1 for my OS. I am in the process of updating everything, and this is my first time using Linux (previously used only Microsoft Windows). When I first attempted to update Firefox, it recommended downloading the latest version. So, I saved the download to a USB drive, removed the older version of Firefox from my laptop, and attempted to reinstall. Problem occurs at this point. I have clicked on everything in the uncompressed folder to try to reinstall Firefox, but nothing works [to reinstall]. I am temporarily using another web browser, but Firefox is my preferred. I went back to the Firefox website to reinstall directly from the site, but I encounter the same problem. What am I doing wrong? What steps can I take to reinstall the latest version of Firefox?

Additional System Details

This happened

Every time Firefox opened

This started when...

Tried to update, then reinstall.

Installed Plug-ins

None, as of yet.

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/534.26+ (KHTML, like Gecko) Version/5.0 Safari/534.26+ Ubuntu/10.10 (2.30.6-1ubuntu5) Epiphany/2.30.6

More Information

I have attempted to reinstall from the Firefox website. I restarted my laptop. I searched through Firefox's troubleshooting articles. Am not posting my question due to a lack of finding a way through this.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

You need to move all the files in the tar.bz2 archive to a Firefox installation directory (e.g. /usr/local/firefox as root).

See:

Question owner

Thanks for the help! Do I need to unzip/decompress the file, first?

I tried moving the files to "/usr/local/firefox as root", but I get as far as "local". There is no Firefox folder, nor will Ubuntu let me create one. In addition, I tried creating and moving from a different file (thinking I could trick the OS in to "creating" a file), but it still did not let me move the file to "/usr/local".

What else can I try?

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

You need to create a firefox program directory yourself to install Firefox in.
You can only make changes to /usr/local if you do that as a root user.
File managers usually have a menu entry or toolbar button to switch to root (superuser) and also allow to open tar.bz2 archive easily.
If you have a file manager with two panes (e.g. Krusader) then you can easily copy files from one pane to the other or you can select all files and copy them to the clipboard and past them in the destination folder.

An alternative is to install Firefox in your home directory (~ or /home/<user>/firefox), then you do not need root access to install and update Firefox.