X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

get a blank page when I click on a link on a website

Posted

get a blank page when I click on a link on websites

Additional System Details

Sites Affected

http://www.ic-parish.com/

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2

More Information

Tobbi
  • Moderator
67 solutions 450 answers

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96778 answers

Helpful Reply

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

If it does work in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

See also:

Question owner

To Cor-El..I appreciate you giving me a response. The problem is that I don't know enough of the terms you are using. For example, when you mention that the extensions will be disabled, I don't know what that means and it sounds complicated. I am game to try something, but, I would like to know what the outcomes are and the difficulty in getting the problem solved.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96778 answers

Helpful Reply

Extensions are used to customize Firefox.
You can see the installed extensions (if you have any) in Tools > Add-ons > Extensions.

See:

Question owner

Thank you, I did check as you suggested and I don't have any extensions. What would be the next step? And, thanks for your patience with this process.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96778 answers

Are you left clicking the link?

Does it make a difference if you middle click with the mouse scroll wheel (if you have such a mouse) or try top open a link in a new tab via the right-click context menu?

Can you open links like a bookmark in another tab with a middle-click with the mouse scroll wheel?

Question owner

Hi, I have a MAC and my mouse doesn't have a middle scroll thing. You lost me with that second part of opening a link via the right-click context menu....what is the latter?

Thanks, eea

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96778 answers

The right-click context menu of a link has an item to open a link in a new tab ("Open Link in New Tab")


You can try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

Question owner

Is there any way to speak with you over the phone, it will simplify this whole process...I do appreciate the efforts you are making, but, it's getting

complicated, I think, unnecessarily so.....
jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Is the problem with these links:

  • Current Weekly Bulletin
  • Current issue of IC Good News

Those both open PDF documents. There have been some problems reported with the Adobe Acrobat plugin in Firefox for Mac. You could try disabling it. Hopefully this will not be too difficult to follow:

Open the add-ons page in a new tab here:

Tools > Add-ons > Plugins category

Find Adobe Acrobat and click the Disable button.

Return to the site and try the links again. What I would expect to happen is for Firefox to ask whether you want to Open or Save the document.

Any luck?

Modified by jscher2000

Question owner

Thanks for another response.

BEFORE I start your steps, don't I want adobe acrobat functioning again? I think I need it to open documents.....Thanks!

Question owner

I went ahead and checked out the section you mentioned and saw that I could enable Adobe Acrobat.

I went back to the website where I had the problem. I got a window asking that I open it, I clicked OK and got alot of code.....but, no bulletin......

What do you think now? Thanks.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

I am a Windows user, so this is not based on personal experience. Based on reading past threads here, Mac users have had better luck disabling the Adobe Acrobat plugin and then having Firefox "Always ask" whether to open the file externally in Adobe Reader or Apple's Preview app.

Question owner

Thanks AGAIN! I guess I need an understanding of what Adobe Acrobat does......if I disable it, will it only effect opening up documents?

If so, I feel comfortable about disabling it.

By the way, I tried disabling it again, based on your recommendation and instead of opening the document, I saved it and THEN I got the document in full!!!! I was so excited. Thanks!

Esther

xdrone 0 solutions 3 answers

clicking on a link in any mail software, opens firefox with a blank new tab. while firefox still running and clicking again on the link in the mail software opens the page again in a new tab in firefox. still i have no solution.

Modified by xdrone

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi xdrone, I think your issue is different than the one that afflicted the original poster. Could you start a new question?

https://support.mozilla.org/questions/new/desktop/fix-problems

Scroll to the bottom of that page to post your own question because I don't think you will find a support article right on point. Please indicate which mail program you use and include your add-ons and setting information with your post.

By the way, if you have any of the following settings, they could be causing the problem. If any of these apply, please mention that so people familiar with those issues can suggest workarounds:

  • Firefox running in a "sandbox"
  • Running "portable" version of Firefox
  • Starting up Firefox with the -no-remote command line switch
  • Using Thunderbird as the mail client and starting Thunderbird with the -no-remote switch