X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Tabs on bottom option missing.

Posted

Firefox crashed the other night. Multiple "resets" to get something to work.

Fine now, except the tabs are on top, and the option ("click on a toolbar") doesn't show the "move tabs" option anymore.

Did a reset - no change.

Downloaded and installed again - no change.

Crash appeared to result from restarting Windows at the request of another application while Firefox was still running.

?

Chosen solution

for the moment you can still manually change that behaviour - enter about:config into the firefox location bar (confirm the info message in case it shows up), search for the preference named browser.tabs.onTop & toggle it to false by double-clicking it.

however this setting might lose its effect in a future version of the browser, for more information also see www.ghacks.net/2012/07/26/mozilla-tabs-on-bottom-feature-needs-to-go/

Read this answer in context 11

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 4.1.10329.0
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • Version 1.0.1, copyright 1996-2009 The VideoLAN Teamhttp://www.videolan.org/
  • 1.9.0009.1
  • npsnapfish
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp
  • Yahoo! activeX Plug-in Bridge
  • Rhapsody Player Engine Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Firefox 15.0.1, Windows Vista (current). Looks like your guesses are accurate.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

Chosen Solution

for the moment you can still manually change that behaviour - enter about:config into the firefox location bar (confirm the info message in case it shows up), search for the preference named browser.tabs.onTop & toggle it to false by double-clicking it.

however this setting might lose its effect in a future version of the browser, for more information also see www.ghacks.net/2012/07/26/mozilla-tabs-on-bottom-feature-needs-to-go/

Modified by philipp

Question owner

madperson:

Thanks!

The "about:config" hack worked....

For some reason, "search" didn't seem to work on that page, but I was using GoToMyPC to access that machine, and it sometimes does odd things....

And, I do fell compelled to register a solid preference for the tabs in their traditional place :D....

Took a while to get used them at all, but I'm hooked now. Definitely a preference for Firefox, too, although the Android version never excited me. Crappy as it is, the built-in (Droid X, but don't ask me which software release) is just easier for me most of the time.

Regards,

Stu..

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Current Firefox versions only show the "Tabs on Top" menu entry in the "View > Toolbars" menu and in context menus if the tabs aren't in the default position on top.

If the tabs are on top and the menu entry isn't available and you want to move the tabs below the navigation toolbar then you need to flip the browser.tabs.onTop pref to false on the about:config page as already posted above.

Helpful Reply

cor-el:

Thanks.... As you can see, madperson pointed me to the magic needed to fix this. No idea why it broke itself. Originally, when installing the first "tabs in the wrong place" version, I found the tweak easily, but it just vanished when Firefox crashed the other day.

It's back now....

The rest of the program seems to be back, too.

Again, thanks to everybody!

Stu.