X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Pages are loading really slow about 20 seconds after I updated to 15.0.1

Posted

I updated my Firefox to 15.0.1 which I did not want to do, but it kept harassing me to do it and now the pages take forever to load. Anytime I go to my Earthlink email, it just loads and loads until it hit the stop "x" and then sometimes it will load. I did not change anything on my computer. All I did was update the browser. When I load the exact same pages in Safari, they load right away. I have tried looking online and found that many users have the same issue. I tried many of their suggestions and nothing worked. I use an iMac 10.6.8.

Additional System Details

This happened

Every time Firefox opened

This started when...

After I updated to the new version of Firefox

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Java Plug-In 2 for NPAPI Browsers
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 4.0.50826.0
  • DivX Web Player version 2.0.3.4
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Grandpa Can Fix Anything 0 solutions 13 answers

gandgsand,


You might want to consider getting the latest BETA of FF 19 at https://www.mozilla.org/en-US/firefox/all-beta.html . I've been using it and it is faster than previous versions (and very stable). It adds it's own PDF reader which is pretty darn quick. This might be your best option to try.

The problem is that, unlike Apple computers which are tightly controlled by Apple, PCs are the wild west and every computer becomes pretty unique over time. At some point, some setting or combination of settings and programs can make other programs run slowly or not at all (you'd be amazed at the conflicts I've run into over the decades).

So while you're running into these very real problems with FF 18, most other folks are not. One thing I've noted with new editions of FireFox is that add-ons often do not get updated and an outdated add-on can be the cause of myriad problems. So you'd be very prudent to first update your add-ons (in your menu, click on "Tools" then "Add-ons." Selected "Extensions" and then, click on the icon near the top on the right that looks like a wheel. Select "Check for Updates." Make a list of those that updated. After they've all loaded, restart FireFox. Then for those that did not update, visit their home pages to confirm that you have the current version -- and if you don't, install the newest version. To get to their home pages from with in the Add-On Manager, click on the underlined "more" link for the update and you'll see the link for its homepage. Also make sure that the "Automatic updates" is checked. This may help you.

I know it's hard to be patient with computers and their software. Computers really are dumb -- they just do what they are they are told to do by their software and their users. So patience with them is a virtue, no matter how frustrating the computer can be. They've driven me batty many times and I've built about 70 of them.

Good luck. I'm most curious to learn what finally works for you.

Modified by Tyler Downer

trustwiz2 0 solutions 1 answers

Found the problem !!!!! I had the same problem as everyone else. The problem was Adblock Plus. Get rid of it and use Adblock Edge and watch your pages load very fast.