X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

pdf files not listed in the preferences/application list, pdf won't load

Posted

I am using Mountain Lion and have Adobe reader 10.1.4 installed. When I click on a site to download a pdf file, I get a blank screen and no download (worked fine before mountain lion) I went to the preferences/applications screen and pdf isn't listed in the app list. How can I get to appear there so that I can assign an action to use reader to open it.

Chosen solution

With earlier versions of MacOS, some users have reported that they have to disable the Acrobat plugin in Firefox and fall back on the Mac's default PDF reader when this happens. To try that, use

Tools > Add-ons > Plugins category

Does it work on Mountain Lion?

As for preferences, it is tricky to manually edit the settings file (mimeTypes.rdf) so hopefully that won't be necessary.

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.4 r402
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Plugin for Wacom tablets.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.4

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Chosen Solution

With earlier versions of MacOS, some users have reported that they have to disable the Acrobat plugin in Firefox and fall back on the Mac's default PDF reader when this happens. To try that, use

Tools > Add-ons > Plugins category

Does it work on Mountain Lion?

As for preferences, it is tricky to manually edit the settings file (mimeTypes.rdf) so hopefully that won't be necessary.

Helpful Reply

I disabled Acrobat as you suggested and it immediately corrected the problem. Then I changed from preview to Reader in the open with dialogue.

ronin65 0 solutions 1 answers

The suggestion appears to work with Firefox 17.x on OS 10.8.2, but I have to wonder why Mozilla have not sorted this out by now.

I would expect that there are a lot more people who have not found this helpful suggestion than have and I would expect that many of them may have changed browsers as a consequence.