X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox takes 1 minute or more to open pages.

Posted

Hey, Recently updated to Firefox 15, now all webpages take at least 1 minute to load. However, there is no internet issue, it's really strange. For example, I'll open four different websites, they'll all say 'Connecting to x' or 'Waiting for x' and just stay there for a minute. After a while, they'll all load as usual at the same time. It's like Firefox has loaded the pages but just isn't displaying them, while this was happening once, I tried resetting the router to see if there was an error there and it still loaded the page after 1 minute, while there was no internet connection available.

I've tried - disabling firewall, anti virus, reinstalling Firefox, restarting router and disabling plugins. Other internet browsers work with no problem.

Thanks

Chosen solution

Could you try disabling Firefox's hardware graphics acceleration? Due to recent graphics drivers, more people are having problems with this feature.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved or at least improved?

Read this answer in context 3

Additional System Details

This happened

Every time Firefox opened

This started when...

2days ago

Installed Plug-ins

  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • VLC media player Web Plugin 2.0.2
  • npFFApi
  • DivX VOD Helper Plug-in
  • DivX Web Player version 1.5.0.52

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

jscher2000
  • Top 10 Contributor
2359 solutions 20906 answers

Chosen Solution

Could you try disabling Firefox's hardware graphics acceleration? Due to recent graphics drivers, more people are having problems with this feature.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved or at least improved?

Question owner

Thanks jscher, as far as I can tell, your solution solved it.

graverholt 0 solutions 14 answers

Where and how do I disable Firefox's hardware graphics acceleration

jscher2000
  • Top 10 Contributor
2359 solutions 20906 answers

Hi graverholt, if you are running Windows, see my earlier post.

If you are using Mac or Linux, your Options dialog is called Preferences and you can find it here:

Mac: Firefox > Preferences > Advanced

Linux: Edit > Preferences > Advanced

Then, on the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

Were you able to find it?

graverholt 0 solutions 14 answers

Yes, thanks, it seems to solve the problem

graverholt 0 solutions 14 answers

No. It did not. I have soon had enough of FF - almost not one single hour without problems

jscher2000
  • Top 10 Contributor
2359 solutions 20906 answers

Hi graverholt, could you start a new question with more information about what's going wrong? Please include your list of add-ons.

https://support.mozilla.org/en-US/questions/new/desktop/fix-problems

If the suggestions provided by the next page in that process are not helpful, scroll down to proceed to the posting form.

bootspur 0 solutions 1 answers

Version 18.02 is slow and times out, testing Safari as a simple baseline, Firefox is awfully slow with Safari the link goes right thru, that is not the case with Firefox the wheel spins, and spins, and spins, then times out.

graverholt 0 solutions 14 answers

Yes, I could send the list of add ons, if FF had not been to stupid as to make it impossible to copy paste the list

graverholt 0 solutions 14 answers

Helpful Reply

But perhaps you could provide me with a list of recommend add ons

jscher2000
  • Top 10 Contributor
2359 solutions 20906 answers

Hi graverholt, I'm not sure how we got on the topic of add-ons. Oh wait, I see, I mentioned including those if you post a new question.

For Extensions, you can use the following page to copy and paste. The results are not especially attractive, but frequent readers of this forum usually can sort them out:

Help > Troubleshooting Information

For Plugins, when you start a new topic here, they usually are included under "More system information" but this does not appear for replies.

As for recommendations, it depends on what you need. Very difficult to curate a list that fits everyone.

Modified by jscher2000

graverholt 0 solutions 14 answers

I don't know either, apart from a browser that works.